Check the web server error log on the XS, it might have more diagnostic
info.

On Thu, Apr 23, 2009 at 7:05 PM, Dave Bauer <d...@solutiongrove.com> wrote:

>
>
> On Thu, Apr 23, 2009 at 6:44 PM, Dave Bauer <d...@solutiongrove.com>wrote:
>
>>
>>
>> On Thu, Apr 23, 2009 at 5:52 PM, Carol Farlow Lerche <c...@msbit.com>wrote:
>>
>>> When the client references "schoolserver", it depends on client
>>> configuration where and if it finds it.  Places that can affect this lookup
>>> process are the configuration designating what is your DNS server, the
>>> configuration of your resolver (e.g. does it supply a default domain if the
>>> requested name is not fully qualified.  So if your local domain is
>>> configured to be "mydom.com", schoolserver.mydom.com might be the actual
>>> name that is looked up.  Finally if you have an /etc/hosts file you can
>>> supply a local name for an arbitrary IP address, so you could have a line
>>> there that gave "192.0.2.1 schoolserver"
>>>
>>> If your "schoolserver" is not named schoolserver in your same domain,
>>> just add an /etc/host entry.
>>>
>>
>> Hi, yes i can connect to the XS at http://schoolserver, ping schoolserver
>> etc. It does look like its configured correctly. The SoaS is getting a DHCP
>> address from the XS.
>>
>
>
> I put print e.code in the HTTPError handler in check_server_availble and
> the error code is "403" for Unauthorized. I can connect to Moodle with the
> magic cookie in Browse so I am not sure what is expected for authentication
> for the backup.
>
> Dave
>
>
>>
>> Thanks
>>
>> Dave
>>
>>
>>>
>>> On Thu, Apr 23, 2009 at 1:58 PM, Dave Bauer <d...@solutiongrove.com>wrote:
>>>
>>>> Hi,
>>>>
>>>> I have updated my XS to the lastest code and I have the ds-backup server
>>>> code on there.
>>>> I have ds-backup-client on my client (slightly modified SoaS).
>>>>
>>>> Now I am investigating how this works and I am reviewing ds-backup.py to
>>>> see why my backups are not working.
>>>>
>>>> I am looking around line 114 and I see this
>>>>
>>>>    backup_url = 'http://schoolserver/backup/1'
>>>>
>>>> I see that the serial number from the client is appended to this.
>>>>
>>>> I don't see anything on the XS that responds on this URL. Should this
>>>> respond or do I have the wrong version of this script or I am confused?
>>>> If something should respond on this URL, is it part of Moodle, ds-backup
>>>> server or something else?
>>>>
>>>> Thanks!
>>>> Dave
>>>>
>>>> --
>>>> Dave Bauer
>>>> d...@solutiongrove.com
>>>> http://www.solutiongrove.com
>>>>
>>>> _______________________________________________
>>>> Server-devel mailing list
>>>> Server-devel@lists.laptop.org
>>>> http://lists.laptop.org/listinfo/server-devel
>>>>
>>>>
>>>
>>>
>>> --
>>> "I don't consider him a particularly reliable source of information."
>>>
>>> -- Secretary of State Hillary Clinton, at a House Foreign Affairs
>>> Committee meeting, on former Vice President Dick Cheney.
>>>
>>
>>
>>
>> --
>> Dave Bauer
>> d...@solutiongrove.com
>> http://www.solutiongrove.com
>>
>
>
>
> --
> Dave Bauer
> d...@solutiongrove.com
> http://www.solutiongrove.com
>
> _______________________________________________
> Server-devel mailing list
> Server-devel@lists.laptop.org
> http://lists.laptop.org/listinfo/server-devel
>
>


-- 
"I don't consider him a particularly reliable source of information."

-- Secretary of State Hillary Clinton, at a House Foreign Affairs Committee
meeting, on former Vice President Dick Cheney.
_______________________________________________
Server-devel mailing list
Server-devel@lists.laptop.org
http://lists.laptop.org/listinfo/server-devel

Reply via email to