It would have to work in Linux before slurm could use it. Here is the red hat 
guide.
https://access.redhat.com/documentation/en-US/Red_Hat_Enterprise_Linux/6/html/Resource_Management_Guide/ch-Using_Control_Groups.html

________________________________
From: Somayah H <somayahass...@gmail.com>
Sent: Saturday, August 12, 2017 4:37:51 AM
To: slurm-dev
Subject: [slurm-dev] cgroup error

Hi Slurm-Dev,

I again tried setting up SLURM but it is not able to setup the cgroups.

I tried setting up the cgroups manually, but I am getting the error that the 
filesystem of type cgroup is unknown. I looked around for some solution but 
have been unable to find it.  Does anyone have any recommended solution to fix 
this issue?

root@mini12:/home/utilite# slurmd -cDvvv
slurmd: topology NONE plugin loaded
slurmd: debug:  Reading cgroup.conf file /etc/slurm-llnl/cgroup.conf
slurmd: debug2: unable to open '/cgroup/freezer//release_agent' for reading : 
No such file or directory
slurmd: debug2: unable to get parameter 'release_agent' for '/cgroup/freezer/'
mount: unknown filesystem type 'cgroup'
slurmd: error: unable to mount freezer cgroup namespace
slurmd: error: Couldn't load specified plugin name for proctrack/cgroup: Plugin 
init() callback failed
slurmd: error: cannot resolve proctrack plugin operations for proctrack/cgroup
slurmd: error: slurmd initialisation failed


Thanks.

Reply via email to