Hi Christian,

Thank you for the suggestion, using ‘-d sat’ worked. I’ll do as you suggest and 
report the result to smartmoxntools-database mailing list.

Kind regards,


On 7 Jan 2017, at 15:32, Christian Franke <christian.fra...@t-online.de> wrote:

Colin Payne wrote:
> I am using a USB to mSATA SSD board “Pi-102” manufactured by Lycom 
> (http://www.lycom.com.tw/Pi-102.htm)
> The Pi-102's USB bridge chip is upd720231A manufactured by Renesas 
> (https://www.renesas.com/en-eu/products/usb-assp/upd720231a.html)
> I’m running Smartmontools on a Raspberry Pi 3, and when I run:
> $ sudo smartctl --all /dev/sda -s on
> …I expected to see a detailed report of the drive data, but instead I got:
> /dev/sda: Unknown USB bridge [0x045b:0x0229 (0x000)]
> Please specify device type with the -d option.

Try '-d sat' option and report the result to smartmontools-database mailing 

If SAT works, we could later add this USB ID to drivedb.h. Then this option 
will be no longer needed for this bridge. Note that you could also add a local 
drive database entry. See section about '-B' option on smartctl man page.


Developer Access Program for Intel Xeon Phi Processors
Access to Intel Xeon Phi processor-based developer platforms.
With one year of Intel Parallel Studio XE.
Training and support from Colfax.
Order your platform today. http://sdm.link/xeonphi
Smartmontools-database mailing list

Reply via email to