Hi All-


I'm having an interesting issue where none of our software channels are
creating any repomd.xml files.  There is a long history with this server,
which may or may not be relevant to this problem, but it's worth mentioning
that this used to be a physical machine running 2.6 that we upgraded to 2.7.
After running in to various issue, we migrated the server to a VM running
2.7 using the procedure discussed here


I have tried manually restarting taskomatic and also using the spacecmd
commands to regenerate the yum repodata, but nothing is being created in
/var/cache/rhn.  The repodata directory is completely missing.  I checked
the taskomatic logs and I don't see any errors that would point to an issue,
not sure where else to check.  


When running a yum list from a client, we get an error that the repomd.xml
file (not surpsingly) couldn't be found.  Out of curiosity, I tried manually
copying over the old /var/cache/rhn/repodata directory over from the old
server and after doing so, I can get past the repomd.xml error, but
obviously this isn't good if these repo files aren't updating.  


Attachment: smime.p7s
Description: S/MIME cryptographic signature

Spacewalk-list mailing list

Reply via email to