I've hit similar issues after the upgrading 2.6 -> 2.7

Try following:
Go to Admin -> Task Schedules
Click on one schedule name ( eg. auto-errata-default ) and then Update schedule 
Do this for all schedules. You will notice that the "Active From" date will be 
updated with a more recent date/time.
Restart taskomatic.

After this taskomatic should behave and pickup the queue properly.

Let me know if that helped.


----- Original Message -----
From: "Glennie, Jonathan - 0443 - MITLL" <jrgle...@ll.mit.edu>
To: "Robert Paschedag" <robert.pasche...@web.de>, spacewalk-list@redhat.com
Sent: Thursday, February 22, 2018 3:52:42 PM
Subject: Re: [Spacewalk-list] Server not creating/updating /var/cache/rhn after 

We have selinux disabled.

Any idea what is supposed to trigger the taskomatic actions?  I noticed in the 
web UI that it is set up with a custom quartz format to run "0 * * * * ?", not 
sure if that is normal or not but it doesn't seem like it.  I'm guessing that 
the reposync commands set a flag somewhere that the repo data needs to be 
updated, and then when the taskomatic job runs, it checks to see if any of the 
repos are in need of an update and generates new repo data if need be? 
Perhaps I should just change the cron to hourly.

I'm not sure what you mean by synchronization of the report.  If you mean the 
report in the web UI, it does not seem to be working.  All of the clients in 
the UI show that they are up to date, however manually running a yum update on 
a client will return a list of many packages that need to be updated.  Is 
there another taskomatic job that is supposed to handle generating the summary 
reports in the Web UI?  Perhaps that job is not running as it should either.

-----Original Message-----
From: Robert Paschedag [mailto:robert.pasche...@web.de]
Sent: Wednesday, February 21, 2018 12:51 AM
To: spacewalk-list@redhat.com; Glennie, Jonathan - 0443 - MITLL 
<jrgle...@ll.mit.edu>; spacewalk-list@redhat.com
Subject: Re: [Spacewalk-list] Server not creating/updating /var/cache/rhn 
after upgrade

Am 20. Februar 2018 20:34:36 MEZ schrieb "Glennie, Jonathan - 0443 - MITLL" 
>Hi All-
>I'm having an interesting issue where none of our software channels are
>creating any repomd.xml files.  There is a long history with this
>server, which may or may not be relevant to this problem, but it's
>worth mentioning that this used to be a physical machine running 2.6
>that we upgraded to 2.7.
>After running in to various issue, we migrated the server to a VM
>2.7 using the procedure discussed here
>I have tried manually restarting taskomatic and also using the spacecmd
>commands to regenerate the yum repodata, but nothing is being created
>in /var/cache/rhn.  The repodata directory is completely missing.  I
>checked the taskomatic logs and I don't see any errors that would point
>to an issue, not sure where else to check.
>When running a yum list from a client, we get an error that the
>repomd.xml file (not surpsingly) couldn't be found.  Out of curiosity,
>I tried manually copying over the old /var/cache/rhn/repodata directory
>over from the old server and after doing so, I can get past the
>repomd.xml error, but obviously this isn't good if these repo files
>aren't updating.

This sounds as if taskomatic is not running the jobs for recreating the repos.

If you have selinux enabled, please check the selinux permissions if that 
directory or reset them.

Does the synchronisation of the report work?


Spacewalk-list mailing list

Spacewalk-list mailing list

Reply via email to