I've been moving on with this mystery. Have removed and reinstalled via pip 
along with pip upgrade. Still no luck, but I get a different output:
Traceback (most recent call last):
"/home/rstyles/.local/lib/python3.5/site-packages/pip/basecommand.py", line 
215, in main
    status = self.run(options, args)
line 342, in run
"/home/rstyles/.local/lib/python3.5/site-packages/pip/req/req_set.py", line 
784, in install
line 851, in install
    self.move_wheel_files(self.source_dir, root=root, prefix=prefix)
line 1064, in move_wheel_files
  File "/home/rstyles/.local/lib/python3.5/site-packages/pip/wheel.py", 
line 345, in move_wheel_files
    clobber(source, lib_dir, True)
  File "/home/rstyles/.local/lib/python3.5/site-packages/pip/wheel.py", 
line 316, in clobber
line 83, in ensure_dir
  File "/usr/lib/python3.5/os.py", line 241, in makedirs
    mkdir(name, mode)
PermissionError: [Errno 13] Permission denied: 

Thanks again for reading.

On Sunday, August 6, 2017 at 11:03:06 AM UTC-7, baile...@gmail.com wrote:
> Just installed Spyder.
>  2.7 appears to run OK. Tried to run spyder3 and there is only a flash of 
> the logo on the screen. When I try to launch from the command line I get 
> this response:
> Traceback (most recent call last):
>   File "/usr/bin/spyder3", line 3, in <module>
>     start_app.main()
>   File "/usr/lib/python3/dist-packages/spyderlib/start_app.py", line 114, 
> in main
>     from spyderlib import spyder
>   File "/usr/lib/python3/dist-packages/spyderlib/spyder.py", line 155, in 
> <module>
>     from spyderlib.utils.environ import WinUserEnvDialog
>   File "/usr/lib/python3/dist-packages/spyderlib/utils/environ.py", line 
> 17, in <module>
>     from spyderlib.widgets.dicteditor import DictEditor
>   File "/usr/lib/python3/dist-packages/spyderlib/widgets/dicteditor.py", 
> line 39, in <module>
>     from spyderlib.widgets.dicteditorutils import (sort_against, get_size,
>   File 
> "/usr/lib/python3/dist-packages/spyderlib/widgets/dicteditorutils.py", line 
> 78, in <module>
>     import bs4
>   File "/usr/lib/python3/dist-packages/bs4/__init__.py", line 30, in 
> <module>
>     from .builder import builder_registry, ParserRejectedMarkup
>   File "/usr/lib/python3/dist-packages/bs4/builder/__init__.py", line 314, 
> in <module>
>     from . import _html5lib
>   File "/usr/lib/python3/dist-packages/bs4/builder/_html5lib.py", line 70, 
> in <module>
>     class TreeBuilderForHtml5lib(html5lib.treebuilders._base.TreeBuilder):
> AttributeError: module 'html5lib.treebuilders' has no attribute '_base'
> System is Mint 18.1 Serena 64bit
> I tried changing the command in the desktop launcher by adding a "3" to 
> the "spyder" command. No luck.
> Not sure what else is needed here to help define the problem. Can access 
> lots of system help if needed.
> Thanks for reading this.

You received this message because you are subscribed to the Google Groups 
"spyder" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to spyderlib+unsubscr...@googlegroups.com.
To post to this group, send email to spyderlib@googlegroups.com.
Visit this group at https://groups.google.com/group/spyderlib.
For more options, visit https://groups.google.com/d/optout.

Reply via email to