On 04/06/2018 11:31 AM, Aqs Younas wrote:
Greetings list.

This might not be related to Kamailio but I thought someone would be able to give a hand in resolving dependency during the installation of rtpengine on Debian 8 Jessie.

It is complaining about below dependencies.

root@debian-769mb-miami-01:/usr/src/rtpengine# dpkg-buildpackage
dpkg-buildpackage: source package ngcp-rtpengine
dpkg-buildpackage: source version 6.3.0.0+0~mr6.3.0.0
dpkg-buildpackage: source distribution unstable
dpkg-buildpackage: source changed by Sipwise Jenkins Builder <jenk...@sipwise.com <mailto:jenk...@sipwise.com>>
dpkg-buildpackage: host architecture amd64
 dpkg-source --before-build rtpengine
dpkg-source: info: using options from rtpengine/debian/source/options: --extend-diff-ignore=.gitreview dpkg-checkbuilddeps: *Unmet build dependencies: debhelper (>= 10~) libbcg729-dev* dpkg-buildpackage: warning: build dependencies/conflicts unsatisfied; aborting
dpkg-buildpackage: warning: (Use -d flag to override.)


I tried to install debhelper from deb but complained from dh-autoreconf and that itself complained abount debhelpler. So, no one is being installed.

Also, If someone can help me how to resolve dependency for libbcg729-dev too.

Any pointer or hint or link to some installation guide would be more than welcome.

Debhelper is a regular Debian package and can be installed with apt-get.

The bcg729 dependency is addressed in the readme: https://github.com/sipwise/rtpengine#g729-support

Cheers
_______________________________________________
Kamailio (SER) - Users Mailing List
sr-users@lists.kamailio.org
https://lists.kamailio.org/cgi-bin/mailman/listinfo/sr-users

Reply via email to