Got this error after resolving the dependencies.

//usr/lib/libflite_cmu_us_kal.so.1: undefined reference to `cmu_postlex'
//usr/lib/libflite_cmu_us_awb.so.1: undefined reference to `usenglish_init'
//usr/lib/libflite_cmu_us_awb.so.1: undefined reference to `cmu_lex_init'
collect2: error: ld returned 1 exit status
../lib/common.Makefile:7: recipe for target 'rtpengine' failed
make[3]: *** [rtpengine] Error 1
make[3]: Leaving directory '/usr/src/rtpengine/daemon'
../lib/common.Makefile:4: recipe for target 'all' failed
make[2]: *** [all] Error 2
make[2]: Leaving directory '/usr/src/rtpengine/daemon'
debian/rules:26: recipe for target 'override_dh_auto_build-arch' failed
make[1]: *** [override_dh_auto_build-arch] Error 2
make[1]: Leaving directory '/usr/src/rtpengine'
debian/rules:23: recipe for target 'build' failed
make: *** [build] Error 2
dpkg-buildpackage: error: debian/rules build gave error exit status 2


Any help :)

Regards,
Aqs Younas

On 7 April 2018 at 03:15, Aqs Younas <aqsyou...@gmail.com> wrote:

> Thanks for the answer.
>
> I had installed debhelper from Debian package but it had Version:
> 9.20150101+deb8u2.
>
> root@debian-769mb-miami-01:/usr/src/rtpengine# dpkg -s debhelper | grep
> '^Version:'
> Version: 9.20150101+deb8u2
>
> Whereas rtpengine demands debhelper* (>= 10~)*
>
> That is why i was trying to install it from debs.
>
> Anyway, I updated my source.list and was able to get the lasted version of
> debhelpler.
>
> Thanks for your help.
>
>
>
>
> On 6 April 2018 at 20:45, Ulrich Henning <hulr...@telba.de> wrote:
>
>> Hi Aqs,
>>
>>
>>
>> just use the corresponding build flag ‘export
>> DEB_BUILD_PROFILES="pkg.ngcp-rtpengine.nobcg729"’ as stated in the
>> readme (https://github.com/sipwise/rtpengine) and your issue should be
>> fixed.
>>
>>
>>
>> BR,
>>
>> Henning
>>
>>
>>
>> *Von:* sr-users [mailto:sr-users-boun...@lists.kamailio.org] *Im Auftrag
>> von *Aqs Younas
>> *Gesendet:* Freitag, 6. April 2018 17:31
>> *An:* Kamailio (SER) - Users Mailing List <sr-us...@lists.sip-router.org>
>> *Betreff:* [SR-Users] rtpengine installation dependencies
>>
>>
>>
>> Greetings list.
>>
>>
>>
>> This might not be related to Kamailio but I thought someone would be able
>> to give a hand in resolving dependency during the installation of rtpengine
>> on Debian 8 Jessie.
>>
>>
>>
>> It is complaining about below dependencies.
>>
>>
>>
>> root@debian-769mb-miami-01:/usr/src/rtpengine# dpkg-buildpackage
>>
>> dpkg-buildpackage: source package ngcp-rtpengine
>>
>> dpkg-buildpackage: source version 6.3.0.0+0~mr6.3.0.0
>>
>> dpkg-buildpackage: source distribution unstable
>>
>> dpkg-buildpackage: source changed by Sipwise Jenkins Builder <
>> jenk...@sipwise.com>
>>
>> dpkg-buildpackage: host architecture amd64
>>
>>  dpkg-source --before-build rtpengine
>>
>> dpkg-source: info: using options from rtpengine/debian/source/options:
>> --extend-diff-ignore=.gitreview
>>
>> dpkg-checkbuilddeps: *Unmet build dependencies: debhelper (>= 10~)
>> libbcg729-dev*
>>
>> dpkg-buildpackage: warning: build dependencies/conflicts unsatisfied;
>> aborting
>>
>> dpkg-buildpackage: warning: (Use -d flag to override.)
>>
>>
>>
>> I tried to install debhelper from deb but complained
>> from dh-autoreconf and that itself complained abount debhelpler. So, no one
>> is being installed.
>>
>> Also, If someone can help me how to resolve dependency for  libbcg729-dev
>> too.
>>
>> Any pointer or hint or link to some installation guide would be more than
>> welcome.
>>
>>
>>
>> Br, Aqs.
>>
>> _______________________________________________
>> Kamailio (SER) - Users Mailing List
>> sr-users@lists.kamailio.org
>> https://lists.kamailio.org/cgi-bin/mailman/listinfo/sr-users
>>
>>
>
_______________________________________________
Kamailio (SER) - Users Mailing List
sr-users@lists.kamailio.org
https://lists.kamailio.org/cgi-bin/mailman/listinfo/sr-users

Reply via email to