Hehe. Guess this is one of those 'religious' coding convention topics ;-) Your right about the warts in this case though, in that the other struts interfaces dont use that convention so it would kinda stand out like a sore thumb.
Hmm. I think Im starting to loose track of the thread here! How come we want it to be an interface again - or is it that we will have a seperate interface for each hook in the RP and one can choose to make classes that implement one or more at the same time, and how does this fit in with the chaining concept for multiple hetrogenous RPs - and for certain hooks you have the problem that the different ones in the chain can 'compete' with each other which will make it hard to come up with something that is generic enough to allow any different RPs to just be plugged without being 'aware' of the others. <ramble-on> Come to think of it, when is struts going to depend on servlet 2.3 and no longer support 2.2? If thats slated for struts 1.2 perhaps you could ditch the AS and RP completely and do something with filters? - though I suppose you still want to organise things a bit more than that so the hooks are called at the right time I guess, so the AS/RP dynamic duo would stay but could be implemented as filters. </ramble-on> -----Original Message----- From: Jeff Robertson [mailto:[EMAIL PROTECTED] Sent: Monday, 2 June 2003 21:04 To: 'Struts Developers List' Subject: RE: composable RequestProcessor > From: Andrew Hill [mailto:[EMAIL PROTECTED] > Sent: Monday, June 02, 2003 8:54 AM > To: Struts Developers List > Subject: RE: composable RequestProcessor > > > <snip> > At this point, I think the main goal is to come up with a decent name > for an interface which RequestProcessor could implement > </snip> > > How about "IRequestProcessor"????? > > (Yeh, okay so Im of the "every interface should start with an > 'I' or the > writer should die!" school of thought, as well as the even > more diabolical > school that thinks "absabludylootly everything should be > accessed through an > interface". ;->) Personally I would prefer the interface itself to have no special tag on its name. It is the job of the implementing classes to give themselves special names. If the interface is going to be what people use most of the time, it should have a nice simple name without warts. My model for this is the Java Collections API. --------------------------------------------------------------------- To unsubscribe, e-mail: [EMAIL PROTECTED] For additional commands, e-mail: [EMAIL PROTECTED] --------------------------------------------------------------------- To unsubscribe, e-mail: [EMAIL PROTECTED] For additional commands, e-mail: [EMAIL PROTECTED]