On 06/17/09 11:08, Mark Hansen wrote:
> On 06/17/09 09:59, Jens Hatlak wrote:
>> Mark Hansen wrote:
>>>   When installing in my profile, I get an error -239, then it says
>>> that "Chrome registration failed".
>> 
>> In that case check the permissions of the files inside and below the 
>> chrome/ directory inside your profile folder. While extensions are 
>> installed permissions are sometimes/often set wrongly. Try something 
>> like this (at your own risk; make a backup if needed):
>> 
>> chmod -R u+rw /path/to/your/SM/profile/chrome/*
> 
> All the files in and under the chrome directory were already rw for
> the owner. I ran the command anyway...
> 
>> 
>> If you have a folder called overlayinfo/ inside your chrome/ folder that 
>> could also be the cause. It's not required for normal SM operation (it's 
>> a relic from the old times) and can be deleted but then you'll have to 
>> reinstall some/all extensions.
> 
> I did have this directory and moved it out of the way. I then installed
> the extension into the Profile area and it said it completed successfully.
> 
> When I run the mail and newsgroup application now, I get the Show HTML
> button (as well as the Preferences page), but when viewing a message
> which includes both HTML and plain text, clicking on the Show HTML
> button doesn't appear to do anything.
> 
> I found several of the following errors in the Error Console:
> 
> Error: no element found
> Source File: 
> jar:resource:///chrome/embed-sample.jar!/content/embed/contents.rdf
> Line: 1, Column: 1
> Source Code:
> 
> Error: no element found
> Source File: 
> jar:resource:///chrome/allowhtmltemp.jar!/content/allowhtmltemp/contents.rdf
> Line: 1, Column: 1
> Source Code:
> ^
> 
> ... among others.
> 
> 
> Note that in my chrome directory, I don't have an embed-sample.jar but there 
> is
> an allowhtmltemp.jar, and it does have the contents.rdf file in the specified
> directory.

Although I'm still getting the above errors to the Error Console when starting
the application, the extension appears to be working now. I don't know what
has changed.

Thanks for your help.
_______________________________________________
support-seamonkey mailing list
support-seamonkey@lists.mozilla.org
https://lists.mozilla.org/listinfo/support-seamonkey

Reply via email to