Dick Baker schrieb:
For years, I've periodically tried installing QT only to be outraged by
the fact that it seizes all video&  audio file associations without
asking.  Over and over, I've banished it from my PCs.

But now, in a moment of weakness (foolishness?), I've bought an iPhone,
and it appears that Apple doesn't like PDF help files--it prefers
tutorials in *.mov format.  So I gingerly tried again to install the
latest version of QuickTime Player (7.6.2).  To my pleasant surprise, it
actually presented an installation option for file and MIME type
associations.  For both, I deselected *everything* except Apple QT movies
(*.mov).

And, to my pleasant surprise, it does not seem to have seized any file
associations on the computer.  BUT when I ran SeaMonkey and went to my
twotonbaker.com site and tried to play mp3 files there, I discovered that
both SeaMonkey (and, for what it's worth, MSIE) were using QT as the
default player for mp3 files, instead of Windows Media Player, which is
what I prefer.

Thinking I could undo this within SeaMonkey, I went to
        Edit>Preferences/Navigator>Helper apps, where I found
        audio/mpeg = .mp3 = open using default

Oddly, it still showed WMP as the default.  So I tried to edit that entry
to set/reset default as WMP, but it reported, "SM can handle this type
internally.  For such types, a helper app will only be invoked if the
server requests external handling."  I went ahead and made the choice,
but this didn't change anything at twotonbaker.com:  mp3s still played by
QT.

So I got deviously clever:  I pulled out my seldom-used Notebook and
uninstalled SeaMonkey, including deleting the Mozilla directory under
docs&  settings.  I then installed QuickTime, being careful not to let it
seize any file associations.  And I checked:  WMP was still the default
app for playing mp3 files.

Only then did I reinstall SeaMonkey.  And to my surprise and horror, the
new installation insisted on opening mp3 files in QuickTime.

What in the world is going on?  QT can't be rewriting SeaMonkey to tell
it to use QT as the mp3 player, because SeaMonkey wasn't there when I
installed QT on the notebook.  And SeaMonkey isn't getting the mp3=QT
association from Windows because it's not there.

I am completely flummoxed.

You were almost there I guess. But the plugins are installed into the program directory, not the profile-directory in documents&settings. So after uninstalling SM make sure to not have a plugins directory with a quicktime plugin left there in the Seamonkey program directory.

Alternatively you can try to find all QT-plugin-files by opening about:plugins (via the address-bar where you type things like www.google.com etc.) in a Seamonkey Browser window. Have a look for all Quicktime Entries there. They always name a filename below their headline. It's very likely that they are named npqtplugin.dll and npqtplugin*.dll (where * is a number from 2 to 5 for example). So find all QT-filenames in your about:plugin-screen, let them search on your harddrive and delete all of them. That should wipe out all Quicktime plugins.
Usually the files are located in X:\Program Files\Seamonkey\plugins
(where X: is the driveletter of your windows-partition, C: on most computers), mine is in D:\Progs\Seamonkey\Plugins for example. I guess you know where you installed your SM to ;-)
kind regards

Martin
_______________________________________________
support-seamonkey mailing list
support-seamonkey@lists.mozilla.org
https://lists.mozilla.org/listinfo/support-seamonkey

Reply via email to