Martin Freitag wrote:
Terje J. Hanssen schrieb:
Terje J. Hanssen wrote:
Hi,

After I upgraded to SM 2.0b1, and now b2 on Linux, SM claims: Cannot
find abook.map
Looking at the SM address book, it now contains only new Collected
addresses, none of the previous SM 1.x saved addresses.

All the old mails are found autmatically from the old profile path to
the mail boxes.

I have searched through my system and cannot find any abook.map file.
Any ideas?


The correct warning message that popup is:
Unable to load address book file abook.mab. It may be read-only, or
locked by another application. Please try again later.


Make sure you didn't have a typo on your search as you had in your post
(map vs. mab!)
SM1.1.x has to have that file somewhere.
You could also try to export in SM1 with the Adressbook and then import
it manually in SM2 address book.
regards

Martin

Obviously I had searched with a typo. Indeed I found four abook.mab on my system related to SM and Mozilla. And yet another for Thunderbird 3.0b.

My mailbox is a legacy one for years with Mozilla and SM on Windows and openSUSE Linux in a multiboot setup. The mailbox is located on a common FAT32 disk, and I setup this path in the preference after installation if neccessary.

SM 2.0b2 address book had only a few new collected addresses. As I could not save save new addresses, it looks as a bug or possibly the file was read only. How is it possible to see the path to which abook.mab SM really is using or change that path?

Below is the result from my search:

linux-1i61:/home/terje # ls -la /home/terje/.mozilla/default/xol9jmvm.slt/abook.mab -rw-r--r-- 1 terje users 58052 2009-08-18 16:22 /home/terje/.mozilla/default/xol9jmvm.slt/abook.mab

I think this one was used by SM 1.1.x, but not used by SM 2.0b2.

linux-1i61:/home/terje # ls -la /home/terje/.mozilla/seamonkey/z7ihv8p2.default/abook.mab -rw-r--r-- 1 terje users 1 2009-08-13 03:05 /home/terje/.mozilla/seamonkey/z7ihv8p2.default/abook.mab

linux-1i61:/home/terje # ls -la /windows/D/Documents\ and\ Settings/-1/Programdata/Mozilla/Profiles/default/uw22i0l7.slt/abook.mab -rw-r--r-- 1 root users 260336 2007-03-19 18:34 /windows/D/Documents and Settings/-1/Programdata/Mozilla/Profiles/default/uw22i0l7.slt/abook.mab linux-1i61:/home/terje # ls -la /windows/D/Documents\ and\ Settings/-1/Programdata/Mozilla/Profiles/Default\ User/ofhikb1c.slt/abook.mab -rw-r--r-- 1 root users 52592 2009-09-17 00:52 /windows/D/Documents and Settings/-1/Programdata/Mozilla/Profiles/Default User/ofhikb1c.slt/abook.mab

These created by Windows on NTFS are owned by root. I tried to chown these to terje, but still root was the owner. Maybe it isn't possible to change access rights on NTFS?

At last I copied the largest one to Linux. Then it worked on SM 2.0b

# cp /windows/D/Documents\ and\ Settings/-1/Programdata/Mozilla/Profiles/default/uw22i0l7.slt/abook.mab /home/terje/.mozilla/seamonkey/z7ihv8p2.default/ linux-1i61:~ # ls -la /home/terje/.mozilla/seamonkey/z7ihv8p2.default/abook.mab -rw-r--r-- 1 terje users 260336 2009-10-04 11:31 /home/terje/.mozilla/seamonkey/z7ihv8p2.default/abook.mab


Rgds,
Terje








_______________________________________________
support-seamonkey mailing list
support-seamonkey@lists.mozilla.org
https://lists.mozilla.org/listinfo/support-seamonkey

Reply via email to