On Saturday, April 04, 2015 10:48:20 AM Bert Massop wrote:
> On 04-04-15 08:04, John Pinkman wrote:
> > I am trying to upload one larger file (few GB), and there is no progress.
> > It says STARTING as a status, and it stays this way for hours.
> > 
> > I tried from VPN, and from regular wifi on different OS, same result. Tor,
> > and torrent client all work fine, but freenet just doesn't work.
> > 
> > There are no error or log messages, it doesn't say what is the problem. I
> > suspect that Freenet expects open ports, or UPnP? It should be able to
> > work without inbound connections.
> > 
> > Any idea what is going wrong?
> Hi John,
> Freenet does indeed expect some ports to be forwarded, and may use UPnP
> (using the UPnP plugin) to open them for you. At least one end of each
> node-to-node link should have its ports forwarded for a connection to
> succeed. If you are connected to enough peers, you should be fine. To
> rule out any weird connectivity issues, please check if you are able to
> retrieve any Freenet page at all (I suggest you try some of the default
> bookmarks). If so, your connectivity is not to blame.
> Inserting files into Freenet is slow, expect it to take quite some time
> for large files. The speed at which you are able to upload depends on
> your configured bandwidth limit, your actual internet connection
> bandwidth, as well as the number of peers you are connected to and their
> bandwidths.
> I'm not entirely sure about the exact semantics of the "starting"
> status. Note however that Freenet only updates the progress of an insert
> after a certain amount of data has been inserted, you might just have to
> wait a bit longer.
> If your problems persist, please also indicate the number of peers you
> are connected to, and please report which Freenet version you are using.
> Thank you for running Freenet!
> -- Bert

Hey Bert,

you got this one wrong:
STARTING is as far as I know not about any network issue. It is about one of 
those I think:
- compressing the file
- encoding the file into Freenet's on-network format. This includes computing 
FEC information for example

If it hangs there, I would suspect one of those issues:
- very large file and slow hard disk. Waiting some more might help
- db4o bugs.

As a conclusion, the following can be said to John to answer this support 
- If you are using the latest regular official Freenet release 1467, then using 
a purge-db4o testing release might help. Instructions how to obtain one are on 
toad's flog, which is in the default bookmarks of Freenet.
- If using the testing release is too complicated, you might just wait for 
1468 to be released. It should be out rather soon (a few weeks).
- There is also a solution available which is even less effort: Try disabling 
compression for the insert. (Please don't do that for many inserts / for ever 
as uncompressed inserts take more disk space on the network)


Attachment: signature.asc
Description: This is a digitally signed message part.

Support mailing list
Unsubscribe at http://emu.freenetproject.org/cgi-bin/mailman/listinfo/support
Or mailto:support-requ...@freenetproject.org?subject=unsubscribe

Reply via email to