> In Swift, we have pretty consistently tried to choose the "right" answer to
> make the resulting language consistent and beautiful.
> I'm perfectly happy to have a discussion about the naming, but I would like
> it to be driven by what we believe the "right" answer is, not simply by
> deference to existing solutions.
Moreover, after your explanation, `lock` feels wrong to me too.
swift-evolution mailing list