Hello Tejpal,

I have few minor comments. You can fix them before pushing this fix.

1. Import individual packages instead of import javax.swing.*.
2. You don't need to create editor1 variable.
3. There should be space after comma editor1,editor2.
4. Rename variables JTextField_Focus_Status, LF according to rules.

Regards,
Pankaj



-----Original Message-----
From: Sergey Bylokhov 
Sent: Monday, January 13, 2020 12:17 PM
To: Tejpal Rebari
Cc: swing-dev@openjdk.java.net
Subject: Re: <Swing Dev> [14] RFR JDK-8223788 - [macos] JSpinner buttons in 
JColorChooser dialog may capture focus using TAB Key

Looks fine.

On 1/12/20 10:32 pm, Tejpal Rebari wrote:
> Hi Sergey,
> 
>> On 13-Jan-2020, at 1:15 AM, Sergey Bylokhov <sergey.bylok...@oracle.com 
>> <mailto:sergey.bylok...@oracle.com>> wrote:
>>
>> Hi, Tejpal
>>
>> Small note that "editor2.getTextField().isFocusOwner()" should be called on 
>> EDT, it is a Swing component.
> 
> I have modified the test.
> webrev : http://cr.openjdk.java.net/~trebari/swing/8223788/webrev3/
> 
> regards
> Tejpal
> 
>>
>> On 1/10/20 1:32 am, Tejpal Rebari wrote:
>>> Hi Sergey,
>>> I had removed the colorchooser and created a frame and added two spinner to 
>>> it.
>>> Then noticed that the issue is reproducible only when the 
>>> ContainerOrderFocusTraversalPolicyis set.
>>> WhenContainerOrderFocusTraversalPolicy is set, in JSpinner there are 
>>> four components which captures focus 1)JSpinner 
>>> 2)JSpinner$NumberEditor 3)JFormattedTextField 
>>> 4)AquaSpinnerUI$SpinPainter In JColorChooser, SlidingSpinner is used 
>>> which sets focusable property to false for1)JSpinner and 
>>> 2)JSpinner$NumberEditor So in the test I 
>>> usedContainerOrderFocusTraversalPolicy and set the focusable property false 
>>> for 1)JSpinner and 2)JSpinner$NumberEditor and then check that the 
>>> spinpainter is capturing focus or not.
>>> Here is the updated 
>>> webrev:http://cr.openjdk.java.net/~trebari/swing/8223788/webrev2/
>>> Regards
>>> Tejpal
>>
>>
>> --
>> Best regards, Sergey.
> 


-- 
Best regards, Sergey.

Reply via email to