Am Samstag, 4. Januar 2014 16:38:39 UTC+1 schrieb Jeremy Ruston: > > I like Okido's suggestion. Stephan - if you're happy to incorporate that > change, please go ahead and submit the pull request when you're ready. > What I don't like about this suggestion are 3 things:
1. Filters at the moment just have one parameter. I want you, Jeremy, to define what should be the parameter seperator. I don't want to use "," when we use, at the moment, most times "|" or even just whitespace. 2. "length" would be nothing but a special keyword here, which can't be used somewhere else. Additionally the filters work with arrays, where we have a length, and objects, where we don't have a length. So in order to get the length we need to loop the whole onject to know the number of members. 3. Isn't "slice" and "length" is too JavaScript-ish? Anyhow: I just noticed, we can get along without length as the javascript slice already works like this: first[n] -> slice[0,n] last[n] -> slice[-n] butfirst[n] -> slice[n] butlast[n] -> slice[0,-n] -- You received this message because you are subscribed to the Google Groups "TiddlyWikiDev" group. To unsubscribe from this group and stop receiving emails from it, send an email to [email protected]. To post to this group, send email to [email protected]. Visit this group at http://groups.google.com/group/tiddlywikidev. For more options, visit https://groups.google.com/groups/opt_out.
