My apologies, I misread Okido's suggestion. I thought the proposal was for
the syntax on the left side of the ">>" signs, but I see now that Stephan's
proposal already incorporates the numeric indices. Anyhow, Stephan's points
are correct.

Best wishes

Jeremy




On Sat, Jan 4, 2014 at 4:01 PM, Stephan Hradek <[email protected]>wrote:

>
>
> Am Samstag, 4. Januar 2014 16:38:39 UTC+1 schrieb Jeremy Ruston:
>
>> I like Okido's suggestion. Stephan - if you're happy to incorporate that
>> change, please go ahead and submit the pull request when you're ready.
>>
> What I don't like about this suggestion are 3 things:
>
>    1. Filters at the moment just have one parameter. I want you, Jeremy,
>    to define what should be the parameter seperator. I don't want to use ","
>    when we use, at the moment, most times "|" or even just whitespace.
>    2. "length" would be nothing but a special keyword here, which can't
>    be used somewhere else. Additionally the filters work with arrays, where we
>    have a length, and objects, where we don't have a length. So in order to
>    get the length we need to loop the whole onject to know the number of
>    members.
>    3. Isn't "slice" and "length" is too JavaScript-ish?
>
> Anyhow: I just noticed, we can get along without length as the javascript
> slice already works like this:
> first[n] -> slice[0,n]
> last[n] -> slice[-n]
> butfirst[n] -> slice[n]
>
> butlast[n] -> slice[0,-n]
>
>



-- 
Jeremy Ruston
mailto:[email protected]

-- 
You received this message because you are subscribed to the Google Groups 
"TiddlyWikiDev" group.
To unsubscribe from this group and stop receiving emails from it, send an email 
to [email protected].
To post to this group, send email to [email protected].
Visit this group at http://groups.google.com/group/tiddlywikidev.
For more options, visit https://groups.google.com/groups/opt_out.

Reply via email to