In an effort to tweak the core a bit more to simplify things:

- Remove ContainerBase.invoke: A Container always has a Pipeline associated with it; as such, the Container interface should have a getPipeline method, and this should be called instead. This will reduce a bit the call stack.

- I noticed the RequestListenerValve was added twice to the pipeline (using the tester). This doesn't seem right, obviously.

- The RequestListenerValve builds the list of the listeners it must notify dynamically, on each request (twice for each request = lots of useless instanceof). This should IMO be done statically in start (with the array of listeners being cleared on stop).

Remy


--------------------------------------------------------------------- To unsubscribe, e-mail: [EMAIL PROTECTED] For additional commands, e-mail: [EMAIL PROTECTED]



Reply via email to