Hi Kostya,

I'm unable to reproduce your issue, unfortunately. Are you still getting a
500 error when trying to connect to streaming via OAuth? Have you tried
using a different access token or even API key? Does the same code/keys work
against the REST API?

Taylor

On Tue, Jul 20, 2010 at 2:58 PM, Kostya Nikolayev <kostya1...@gmail.com>wrote:

> Taylor,
>
> Did the details I posted help to identify the issue?
>
> Thanks,
> Kostya
>
> On Jul 20, 9:56 pm, ap <aashish.pa...@gmail.com> wrote:
> > Looks like the oAuth access token issue is back! Started getting 500's
> > from Twitter API a few minutes ago.
> >
> > On Jul 20, 11:38 am, Kostya Nikolayev <kostya1...@gmail.com> wrote:
> >
> > > Taylor!
> >
> > > This is what I'm sending:
> >
> > > POST /1/statuses/filter.json HTTP/1.1\r\nHost: stream.twitter.com\r
> > > \nUser-Agent: TweetStream\r\nAuthorization: OAuth
> > > oauth_nonce=0IblKRcN17LUBG6zMnQk6DVrObhzcZowIVpPLtsRviU,
> > > oauth_signature=rbGAlSp1VIbuXbk4Wr99jumyi5o%3D,
> > > oauth_signature_method=HMAC-SHA1, oauth_timestamp=1279640138,
> > > oauth_consumer_key=150423549-eAqqrDB7nsbvxE85cHValKZazJ6z4137CEJ6Bnfn,
> > > oauth_token=tnruTl8uNRwGvICnzYpww, oauth_version=1.0\r\nContent-type:
> > > application/x-www-form-urlencoded\r\nContent-length: 13\r\n\r
> > > \ntrack=twitter
> >
> > > Signature base string is:
> >
> > > POST&http%3A%2F%2Fstream.twitter.com%2F1%2Fstatuses
> > > %2Ffilter.json&oauth_consumer_key%3D150423549-
> > > eAqqrDB7nsbvxE85cHValKZazJ6z4137CEJ6Bnfn%26oauth_nonce
> > > %3D0IblKRcN17LUBG6zMnQk6DVrObhzcZowIVpPLtsRviU%26oauth_signature_method
> > > %3DHMAC-SHA1%26oauth_timestamp%3D1279640138%26oauth_token
> > > %3DtnruTl8uNRwGvICnzYpww%26oauth_version%3D1.0%26track%3D
> >
> > > Thanks,
> > > Kostya
> >
> > > On Jul 20, 6:18 pm, Taylor Singletary <taylorsinglet...@twitter.com>
> > > wrote:
> >
> > > > Hi Kostya,
> >
> > > > I'm able to connect to the streaming API over OAuth fine at the
> moment.
> >
> > > > Can you share the full URL, HTTP method, and parameters that you are
> trying
> > > > to access? If possible, also your signature base string?
> >
> > > > Taylor
> >
> > > > On Tue, Jul 20, 2010 at 8:09 AM, Kostya Nikolayev <
> kostya1...@gmail.com>wrote:
> >
> > > > > Taylor,
> >
> > > > > Has Sreaming API OAuth been affected ?
> >
> > > > > Authenticating with the following oauth header gives 500 to me:
> > > > > "OAuth oauth_nonce=N9wgHt2uPw8HqRwtOpjuVDSeuVYmc8UGDF8H0237v0,
> > > > > oauth_signature=ALUT7tKXK%2Fw57SnJulj8x1l%2F7%2Fk%3D,
> > > > > oauth_signature_method=HMAC-SHA1, oauth_timestamp=1279638245,
> > > > >
> oauth_consumer_key=150423549-eAqqrDB7nsbvxE85cHValKZazJ6z4137CEJ6Bnfn,
> > > > > oauth_token=tnruTl8uNRwGvICnzYpww, oauth_version=1.0"
> >
> > > > > Is it Streaming API OAuth issue?
> >
> > > > > Thanks,
> > > > > Kostya
> >
> > > > > On Jul 19, 10:59 pm, Taylor Singletary <
> taylorsinglet...@twitter.com>
> > > > > wrote:
> > > > > > Hi Ap,
> >
> > > > > > This is the right place for reporting issues like this -- well,
> one of
> > > > > the
> > > > > > right places anyway -- we have some issues with OAuth today that
> are
> > > > > related
> > > > > > to some wider issues related to updating objects associated with
> users
> > > > > (like
> > > > > > access tokens).
> >
> > > > > > We hope to have this fixed soon!
> >
> > > > > > Thanks,
> > > > > > Taylor
> >
> > > > > > On Mon, Jul 19, 2010 at 12:53 PM, ap <aashish.pa...@gmail.com>
> wrote:
> > > > > > > I've been experiencing OAuth issues with my app today. If I'm
> already
> > > > > > > logged into twitter, the OAuth redirects to my app just fine.
> However,
> > > > > > > if I have to land on the authentication page and enter my
> username and
> > > > > > > password and click submit, I get the following error:
> >
> > > > > > > Mon Jul 19 15:40:47 EDT 2010 : Twitter exception:
> > > > > > > TwitterException{message=500:Something is broken.  Please post
> to the
> > > > > > > group so the Twitter team can investigate.[Some HTML here],
> > > > > > > statusCode=500, retryAfter=0, rateLimitStatus=null}
> >
> > > > > > > I'm not sure if this is the group that the message is asking me
> to
> > > > > > > post in, if not, please let me know the correct group to post
> to so I
> > > > > > > can get some assistance.
> >
> > > > > > > Thanks!
> >
> >
>

Reply via email to