This reproduces even on http://search.twitter.com.  If you try to
filter to "en" only results you get back 0 items for most queries.
Select "try all languages" from the search portal or remove "lang=en"
from your API query and you get results for your queries (most of
which are in english.)

What's weird is this seemed to be working fine until about 2 days
ago.  And its been very intermittent since.  Yesterday queries would
work for a while then they would stop working (same query to the
API.)  But today they seem to be broken for me all day.  Other members
of my team reported the same issue yesterday so it defenitly seems to
be something on your end.

BTW... When calling the API and this happens we're getting back an
error similar to this:

jsonp1290717568994({"results":[],"max_id":7896158276488192,"since_id":
7896158276488192,"refresh_url":"?
since_id=7896158276488192&q=Thanksgiving","results_per_page":50,"page":
1,"completed_in":0.019352,"warning":"adjusted since_id to
7896158276488192 due to temporary
error","since_id_str":"7896158276488192","max_id_str":"7896158276488192","query":"Thanksgiving"});

I did a search and this error was reported back in June but nobody
ever responded... Crossing my fingers that this message doesn't go
into the void as well...

-- 
Twitter developer documentation and resources: http://dev.twitter.com/doc
API updates via Twitter: http://twitter.com/twitterapi
Issues/Enhancements Tracker: http://code.google.com/p/twitter-api/issues/list
Change your membership to this group: 
http://groups.google.com/group/twitter-development-talk

Reply via email to