Hello,

I really think the problem is with the HEAD command and component reuse 
after abort(). It works fine with GET but for the cache validation, we need 
the HEAD first.

Hope you can help,

SubZero

----- Original Message ----- 
From: "Fastream Technologies" <[EMAIL PROTECTED]>
To: "ICS support mailing" <twsocket@elists.org>
Sent: Tuesday, August 29, 2006 10:30 AM
Subject: [twsocket] Need help with THttpCli reuse after abort()


: Hello,
:
: As you know I am coding a reverse proxy. In my proxy, I am keeping HTTP
: CLIENT connections open after a request so that the next request does not
: wait for the establishment. Now, when something goes wrong (i.e. socket
: error), I abort the client connection as well to reset the internal state
: machine. However, when I do so, in the next request, (which needs to 
reopen
: the socket) it stalls at SocketDataAvailable. It goes to httpwaitingheader
: part but reads data instead of header and cannot find the #10 so exits. 
This
: was not the case when we did not have a cache and did not feel the need to
: send HEAD command before GET. Now it stalls at HEAD!!
:
: Any idea?
:
: Best Regards,
:
: SZ
:
: -- 
: To unsubscribe or change your settings for TWSocket mailing list
: please goto http://www.elists.org/mailman/listinfo/twsocket
: Visit our website at http://www.overbyte.be 

-- 
To unsubscribe or change your settings for TWSocket mailing list
please goto http://www.elists.org/mailman/listinfo/twsocket
Visit our website at http://www.overbyte.be

Reply via email to