> I have uploaded HttpTst executable at 
> http://www.overbyte.be/arch/dump/HttpTst.zip. There is both ICS-V5 and 
> ICS-V6 versions. Would you try with those versions and report here what is 
> displayed (copy/pasted in your email, screen dump would be too large) in the 
> two memos when you check "Display header" and execute the get query ? Try 
> with http/1.0 and http/1.1, everything clear except URL and display header 
> checkbox. Use http://www.overbyte.be as URL for testing.

Hello again Francois, thanks for your swift response.

Using http://wwww.overbyte.be as test URL I found :

Your result -

> You should see in upper memo:
> 
> ---- cute here ----
> Not using proxy
> cmd> GET / HTTP/1.0
> cmd> Accept: image/gif, image/x-xbitmap, image/jpeg, image/pjpeg, */*
> cmd> Connection: Keep-Alive
> cmd> Accept-Language: en, fr
> cmd> User-Agent: Mozilla/3.0 (compatible)
> cmd> Host: www.overbyte.be
> cmd>
> text/html => document.htm
> Location = http://www.overbyte.be
> URL = http://www.overbyte.be
> Document = document.htm
> RequestDone, no error. Status =200
> StatusCode = 200
> hdr>HTTP/1.1 200 OK
> hdr>Date: Sun, 13 Jul 2008 08:34:47 GMT
> hdr>Server: Apache/2.2.6 (Win32) PHP/5.2.5
> hdr>Last-Modified: Wed, 31 Dec 2003 17:48:22 GMT
> hdr>ETag: "16f59-395-585ca310"
> hdr>Accept-Ranges: bytes
> hdr>Content-Length: 917
> hdr>Keep-Alive: timeout=5, max=100
> hdr>Connection: Keep-Alive
> hdr>Content-Type: text/html
> ---- cute here ----

My result -

Not using proxy
cmd> GET / HTTP/1.0
cmd> Accept: image/gif, image/x-xbitmap, image/jpeg, image/pjpeg, */*
cmd> Connection: Keep-Alive
cmd> Accept-Language: en, fr
cmd> User-Agent: Mozilla/3.0 (compatible)
cmd> Host: www.overbyte.be
cmd>
text/html => document.htm
Location = www.overbyte.be
URL = www.overbyte.be
Document = document.htm
RequestDone, no error. Status =200
StatusCode = 200


Your result-

> 
> And in lower memo:
> ---- cute here ----
> <HTML>
> <HEAD>
>  <TITLE>OverByte - HomePage</TITLE>
> 
>                                              [HTML code removed for clarity]
> 
> </BODY>
> </HTML>
> ---- cute here ----

My result -

<HTML>
<HEAD>
        <TITLE>OverByte - HomePage</TITLE>

<!-- START: Meta -->
        <META HTTP-EQUIV="content-type" CONTENT="text/html">
        <META NAME="Generator" CONTENT="EditPlus 1.2">
        <META NAME="AUTHOR" CONTENT="[EMAIL PROTECTED]">
        <META NAME="OWNER" CONTENT="Fran├žois Piette">
        <META NAME="DESCRIPTION" CONTENT="Freeware internet component suite - 
ICS - for Delphi, full source code">
        <META NAME="ROBOTS" CONTENT="all">
        <META NAME="DISTRIBUTION" CONTENT="global">
        <META NAME="RESOURCE-TYPE" CONTENT="document">
        <META NAME="KEYWORDS" CONTENT="ICS, MIDWARE, TCP, UDP, HTTP, SMPT, 
POP3, NNTP, FTP, TELNET, ICMP, FINGER, DELPHI, FREEWARE">
<!-- END: Meta -->

        <META HTTP-EQUIV="Refresh" CONTENT="0;URL=frame_index.html">
</HEAD>
<BODY BGCOLOR="#FFFFFF">
<BR><BR><BR>
<DIV ALIGN="center">
If you are not redirected automatically,<BR>
[<A HREF="frame_index.html">Click Here</A>]
</DIV>
</BODY>
</HTML>

I get these results for *both* executables you sent me and for *both* 
PC1 and PC2 - everything thus seems to work perfectly, with no need for 
any messing around with routers and whatnot. Also, PC1 and PC2 were 
running slightly different versions of ICS, PC2 being the most up to 
date - that doesn't seem to be the problem either. This obviously seems 
really weird now - however, I think the answer is quite simple - ICS on 
PC2 has been corrupted in some way, so the next thing to try is a reinstall.

I noticed when stepping thru HttpTst in the debugger, there is a line I 
think in the GET button click handler :

        HttpCli->Url = URLEdit->Text;
        ... etc for Proxy and so on

- while URLEdit->Text was "http://www.google.com"; or whatever, when 
stepping over this line HttpCli->URL would remain as NULL in value, but 
I thought this was a problem with the debugger (which has its quirks) 
rather than ICS.

regards

Joseph Benson



-- 
To unsubscribe or change your settings for TWSocket mailing list
please goto http://lists.elists.org/cgi-bin/mailman/listinfo/twsocket
Visit our website at http://www.overbyte.be

Reply via email to