>>> It's an page request that generates a 301 status. HttpAsy is not a
>>> threaded application, seems there the same url will then not
>>> generate a problem. HttpThr1 doesn't do a async call so again no
>>> problem. 
>> There should be no difference between running the component in the
>> context of a worker thread or the VCL main thread, provided you did
>> it all right. If the problem cannot be reproduced with one of the
>> demo applications or with a simple, single threaded test application
>> it's likely not a ICS-bug.
> I owe you an apology!  There are no problems reported in my software
> with the latest version ! Sorry!

No problem, that's good news.

> What happened is that the test runs more then several hours. I
> normally stop it after 45 mins because otherwise i need several days
> for just a few test runs. However when the thread terminates the
> calls to the getasync are not correctly stopped (!) and that is when
> the error start appearing. I saw this last night when i suddenly
> noticed that the timestamp for the error message was always at the
> same time as when terminating the thread. 
> I will correct that issue and then run some extra tests to confirm
> that indeed when not using a proxy the issue is solved. 

In my tests with several proxy-configurations it worked as well, 
knock on wood.

Arno Garrels
To unsubscribe or change your settings for TWSocket mailing list
please goto
Visit our website at

Reply via email to