I am going to change back a few parameters I changed in December. Still, the
problem seems to be very selective as it only affects users going into
Universe. I am going to change SEMMNI from 1024 to 2048 and SEMMSL from 256
to 1024 and SHMMNI from 1024 to 2048.
Thanks for the suggestion. I'll post with the results.
Vance

-----Original Message-----
From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED]
Behalf Of Glenn Herbert
Sent: Thursday, February 05, 2004 10:21 AM
To: U2 Users Discussion List
Subject: RE: UV command failing mystery


Ok. So its not an exec/fork problem.  My next suspicion would be having to
do with either SHMxxx or SEMxxxx kernel parameters not being
sufficient.  In the cases where these resources are inadequate it is
possible the OS may boot you out.

At 06:38 PM 02/04/2004, you wrote:
>Well, it did not take long to get a chance to test trying 'uvsh'. The
>problem reared its ugly head again today and we now know that uvsh also
does
>not work. The command returns to the shell so quickly that whatever the
>problem is it must occur near the start of the program. If you happen to
>know what the uvsh does first it may help me figure out where the problem
>may lie. I would have thought that an error of this sort would have been
>recorded in a log file but I have not stumbled across one yet.
>Thanks again,
>Vance Dailey
>
>-----Original Message-----
>From: [EMAIL PROTECTED] [mailto:[EMAIL PROTECTED]
>Behalf Of Glenn Herbert
>Sent: Wednesday, February 04, 2004 10:13 AM
>To: U2 Users Discussion List
>Subject: Re: UV command failing mystery
>
>
>The 'uv' command is basically a small front ender to the 'uvsh' executable,
>which is really the guts of universe.  The uv command does little more (for
>universe) then to check ulimit settings, increasing them when necessary,
>then issuing an execve() call to uvsh.  If you bypass 'uv' and just use
>'uvsh', does the problem still occur?
>
>Your universe configurables seem reasonable, as well as your kernel params,
>but I do recall an issue whereby the OS would disallow exec's (and /or
>forks) due to system resource exhaustion, although it has been a while and
>I cannot recall the details.
>
>At 05:23 PM 02/03/2004, you wrote:
> >We are having a very strange intermittent problem with the UV command not
> >working from Unix.
>
>--
>u2-users mailing list
>[EMAIL PROTECTED]
>http://www.oliver.com/mailman/listinfo/u2-users
>
>--
>u2-users mailing list
>[EMAIL PROTECTED]
>http://www.oliver.com/mailman/listinfo/u2-users

--
u2-users mailing list
[EMAIL PROTECTED]
http://www.oliver.com/mailman/listinfo/u2-users

-- 
u2-users mailing list
[EMAIL PROTECTED]
http://www.oliver.com/mailman/listinfo/u2-users

Reply via email to