can you show us some code ?

-----Original Message-----
Behalf Of Dave Tabor
Sent: Thursday, March 18, 2004 4:18 PM
To: U2 Users Discussion List
Subject: Crazy intermittent problem. Need help as soon as possible.

Hi, Everyone.

I'm having trouble with a scheduling program I'm writing in, on a
WinXPpro system, using UniObjects, that extracts and writes data to a file
in our Unidata 6.0.3 system on an AIX 5.1L system.

The trouble that I'm having is that the data is getting corrupted.  As the
screen doesn't rebuild after a data save, I don't 'see' the problem until I
restart the program the next time around, and data is re-read from the

I've been through my program 3 times, and can't find an error.  I'm assuming
at this point that the error is outside my program, as I ran the same test
data through the program 5 times, and it only corrupted the data 3 times.
The other two it worked flawlessly.  If it was an error in my program, it
shouldn't ever work right, should it?

Also, the program treats every record equally, but the data is
intermittently corrupted, some records process fine, others get corrupted.
Some fields are lost all together.

Fortunately it's still in test mode, so we haven't lost any real data yet.

The data is doing things like this:

                Record 1:       Record 2:
DelDate:        03/18/04        03/18/04         <--OK
SeqNo:  3               3                <--OK
Type:           F               0               <----These two are mixed
together (* see below)
Hours:  0h              hF              <---/
Code:           -                                <===== This one is GONE!!!!
Color:  Blue            WBlu            <----These two are mixed together (*
see below)
Symbol: W               e               <---/
Emp:            1                                <===== This one is
RelNo:  01234567001     N0123456700     <----These two are mixed together (*
see below)
Priority:       N               1               <---/

(* HERE!)  
At first, I thought that the data was being broken up at the wrong points,
but after a closer look, it appears that this is happening.  In each three
line group:
Line1:  Starts with the first character of line two, and loses it's last
Line2:  Loses it's first character to line 1, and gains the last character
of line 1 at the end of it's data.
Line3:  Data is gone (unless it's a <space> character)

It's really crazy.

Anyone have any ideas for this one?  If so, any help is appreciated.

u2-users mailing list

Notice of Confidentiality:  The information included and/or attached in this
electronic mail transmission may contain confidential or privileged
information and is intended for the addressee.  Any unauthorized disclosure,
reproduction, distribution or the taking of action in reliance on the
contents of the information is prohibited.  If you believe that you have
received the message in error, please notify the sender by reply
transmission and delete the message without copying or disclosing it. 

u2-users mailing list

Reply via email to