In a message dated 4/26/2004 5:22:07 PM Eastern Daylight Time, [EMAIL PROTECTED] 
writes:

> I wrote a wrapper for the ED command last week to keep an audit trail of 
> any changes made to files outside our applications.  I'm just writing a 
> before and after version of an edited record to a temp file and 
> comparing afterwards.  All seemed fine until one of my coworkers 
> informed me he could no longer use "X" to drop back to TCL after editing 
> from a select list.  This was due to the fact that I was processing the 
> select list in the wrapper program and just executing ED once for each 
> record.  For "X" to work as it used to, I need to write out all the 
> selected records at the beginning, let ED process the select list, then 
> go back through the list again for comparison.
> 
> Here's the problem:
> No matter what I do, I can't get ED to recognize an active select list 
> that is activated within the wrapper program.  I use "READLIST ITEMS" at 
> the beginning to get the list of items to write to the temp file, then 
> "SELECTN ITEMS TO 0" prior to executing ED.  I also tried writing the 
> list to &SAVEDLISTS& and executing "GET.LIST ":TEMP.LIST prior to 
> executing ED, but got the same result.  These two test 
> programs 
> illustrate the problem:

John what is wrong with this approach
loop
   readnext id else done = true
until done do
   list<-1> = id
repeat
select list to mylist
loop
   readnext id else done = true
until done do
   execute "ed ":file:" ":id
repeat

then before, after, between the two loops you can do whatever you wanted to do
Will
-- 
u2-users mailing list
[EMAIL PROTECTED]
http://www.oliver.com/mailman/listinfo/u2-users

Reply via email to