I can confirm that your suggestion works.  I simply did this:

>>sudo apt install --reinstall python\*-decorator

and apt proceeded to fix the problem.  Here are the details.

sudo apt install --reinstall python\*-decorator
[sudo] password for cad: 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Note, selecting 'python3-decorator' for glob 'python*-decorator'
Note, selecting 'python-decorator' for glob 'python*-decorator'
0 upgraded, 0 newly installed, 2 reinstalled, 0 to remove and 9 not upgraded.
1 not fully installed or removed.
Need to get 18.7 kB of archives.
After this operation, 0 B of additional disk space will be used.
Get:1 http://us.archive.ubuntu.com/ubuntu yakkety/main amd64 python-decorator 
all 4.0.6-1 [9,326 B]
Get:2 http://us.archive.ubuntu.com/ubuntu yakkety/universe amd64 
python3-decorator all 4.0.6-1 [9,388 B]
Fetched 18.7 kB in 0s (46.8 kB/s)            
(Reading database ... 861833 files and directories currently installed.)
Preparing to unpack .../0-python-decorator_4.0.6-1_all.deb ...
Unpacking python-decorator (4.0.6-1) over (4.0.6-1) ...
Preparing to unpack .../1-python3-decorator_4.0.6-1_all.deb ...
Unpacking python3-decorator (4.0.6-1) over (4.0.6-1) ...
Setting up python-decorator (4.0.6-1) ...
Setting up python3-decorator (4.0.6-1) ...
Setting up python3-scipy (0.17.1-1) ...

You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.

  package python3-scipy 0.17.0-1 failed to install/upgrade: subprocess
  installed post-installation script returned error exit status 1

To manage notifications about this bug go to:

ubuntu-bugs mailing list

Reply via email to