** Description changed:

  This is happening on Noble/Caracal charm channel 2024.1/stable  rev. 946
  
  Libvirt 10.0.0-2ubuntu8.19
  Nova 3:29.2.0-0ubuntu1.8
- Qemu 2024.02-2ubuntu0.9
+ Qemu 1:8.2.2+ds-0ubuntu1.18
  
- 
- By default VMs fail to boot from ephemeral disk, they are dropped into grub 
rescue mode.
+ By default VMs fail to boot from ephemeral disk, they are dropped into
+ grub rescue mode.
  
  Reproduced identically on both Noble and Jammy arm64 images.
  
  But then pressing any key, VM can boot just fine. So this rules out
  images builds bug. It looks like a race between the guest first disk
  read and qemu context still warming up.
  
  Workaround
  
  $ juju config nova-compute-arm64 disk-cachemodes="file=writethrough"
  
- 
  Filing against the charm but this looks to be nova/qemu related.

-- 
You received this bug notification because you are a member of Ubuntu
Bugs, which is subscribed to Ubuntu.
https://bugs.launchpad.net/bugs/2169551

Title:
  VMs on ephemeral fails to boot [arm64, amd64]

To manage notifications about this bug go to:
https://bugs.launchpad.net/charm-nova-compute/+bug/2169551/+subscriptions


-- 
ubuntu-bugs mailing list
[email protected]
https://lists.ubuntu.com/mailman/listinfo/ubuntu-bugs

Reply via email to