Thanks for reporting back. It could potentially be useful for others.

http://ubuntustudio.org/merchandise/

As it says there, we don't get any money. But the advertising helps to
spread the word!

As you seem to know what you are doing, helping out here with user
queries is always welcome.

You could also try triaging a few bugs on Ubuntu Studio packages:
https://wiki.ubuntu.com/HelpingWithBugs
Just when you have a spare hour or so here and there. It all helps.

Cheers,

Ross

On 02/23/2018 12:43 PM, Achilleas Mantzios wrote:
> Hello Ross,
> for some reason there was a newer kernel in /boot/ which was not part of
> Ubuntu Studio. The installation didn't touch the kernel, but wiped out
> (as should and expected) all files under /lib/modules for this kernel.
> As a sequence, grub recognized the kernel, being the newest, placed it
> in top, my son kept selecting it being the default, and so there was no
> sound, since there were no drivers in /lib/modules at all. I am puzzled
> even at how the system managed to boot ...
> 
> Another problem prior to that, was the X11 upstart. Due to this I could
> not get XFCE loading completely, so all I kept seeeing was an empty
> screen with the mouse moving (slow).
> 
> The upstart problem was solved by the upgrade. The drivers problem by
> running install-grub from the live CD.
> 
> All went good. My son tells me this better than the previous version.
> 
> You guys are doing a great job.
> 
> I would like to contribute, some way, maybe by buying something I guess.
> Ubuntu Studio must stay alive.
> 
> Thanks.
> 
> On 23/02/2018 12:31, Ross Gammon wrote:
>> Hi Achilleas,
>>
>> Yuck. If you don't stick with the LTS's, you need to keep up to date
>> with the latest release!
>>
>> On 02/21/2018 09:02 AM, Achilleas Mantzios wrote:
>>> Hello list! My son uses and likes Ubuntu Studio for audio/video/gaming.
>>> I am an old Unix die-hard using unix since early SunOS, and also
>>> FreeBSD/Linux since the early 90s.
>>> Ok, enough with the intros, here is the steps that lead to the problem :
>>> At first I tried to upgrade from 16.10 but obviously there was no update
>>> path due to 16.10 being obsolete. Then I tried a hack to force upgrade
>>> directly to artful , by changing /etc/apt/sources.list but this resulted
>>> in an unstable system (no grub, ultra slow USB wireless mouse and
>>> keyboard, etc). And finally decided to bite the bullet, back everything
>>> up and go for a fresh installation. In the process of installation I
>>> decided to keep old user data files (i.e. not format).
>>> Files were kept, but not the exact users -> uid , groups -> gid
>>> mappings. So I had to do some editing there.
>>> Everything seemed to go semi-OK, but then started some more problems.
>>> Mouse/Keaybord were still slow, laggy even lossy (keyboard). I changed
>>> the USB port and keyboard and mouse started behaving good.
>>> Then I decided to test some sound. I am not currently on the box, but i
>>> supposed the tool I used was : xfce4-pulseaudio-plugin . This detected
>>> no audio card. Just a dummy card.
>>>
>>> Can you guys shed some light on what to do next?
>>>
>> I am afraid that I am not the best person to help out here. There is
>> some help (although getting dated) here:
>> https://help.ubuntu.com/community/UbuntuStudio
>>
>> You could also try running from a Live DVD, to compare settings etc.
>>
>> Ralf has also emailed some good troubleshooting commands on this list,
>> if you search the online archives.
>>
>> Let us know how you get on.
>>
>> Ross
>>
> 


-- 
ubuntu-studio-users mailing list
ubuntu-studio-users@lists.ubuntu.com
Modify settings or unsubscribe at: 
https://lists.ubuntu.com/mailman/listinfo/ubuntu-studio-users

Reply via email to