On Jul 9, 2011 8:50 PM, "Yann E. MORIN" <[email protected]>
wrote:
>
>
> commit:
http://git.uclibc.org/uClibc/commit/?id=bda6117489ad3de5abfb008a8cb065c9059cd60c
> branch: http://git.uclibc.org/uClibc/commit/?id=refs/heads/prelink
>
> Add three new blind options to set use of Thumb mode:
> - COMPILE_IN_THUMB_MODE
>  - if set, CFLAGS will contain -mthumb
>  - if unset, the compiler's default is used
> - HAS_THUMB
>  - CPUS with Thumb instruction set can select this
>  - use of BX depends on this
> - FORCE_THUMB
>  - CPUs that are Thumb-only must select this

>  - this selects: HAS_THUMB, COMPILE_IN_THUMB_MODE and USE_BX

I would prefer to name the knob USE_THUMB instead.
Comments?
_______________________________________________
uClibc mailing list
[email protected]
http://lists.busybox.net/mailman/listinfo/uclibc

Reply via email to