On Jul 12, 2011 9:03 PM, "Yann E. MORIN" <[email protected]> wrote: > > Berhnard, All, > > On Tuesday 12 July 2011 20:04:36 Bernhard Reutner-Fischer wrote: > > On Jul 9, 2011 8:50 PM, "Yann E. MORIN" <[email protected] > > > wrote: > > > > > > > > > commit: > > http://git.uclibc.org/uClibc/commit/?id=bda6117489ad3de5abfb008a8cb065c9059cd60c > > > branch: http://git.uclibc.org/uClibc/commit/?id=refs/heads/prelink > > > > > > Add three new blind options to set use of Thumb mode: > > > - COMPILE_IN_THUMB_MODE > > > - if set, CFLAGS will contain -mthumb > > > - if unset, the compiler's default is used > > > - HAS_THUMB > > > - CPUS with Thumb instruction set can select this > > > - use of BX depends on this > > > - FORCE_THUMB > > > - CPUs that are Thumb-only must select this > > > > > - this selects: HAS_THUMB, COMPILE_IN_THUMB_MODE and USE_BX > > > > I would prefer to name the knob USE_THUMB instead. > > Comments? > > I am not a native english-speaker, but to me, USE_THUMB does not convey > the important meaning that Thumb mode is forced; it is not as strong. > Really, I named it thus to highlight the fact that some other config > option did force Thumb to be used. > > Also, the real option that builds in Thumb mode is COMPILE_IN_THUMB_MODE. > FORCE_THUMB is only an internal knob that is here to implement the > dependency logic. > > Moreover, FORCE_THUMB just disapears in the next commit. > > Well, re-reading your mail, I am not sure which symbol you are referring to. > Was it FORCE_THUMB (the last one described), or was it COMPILE_IN_THUMB_MODE > (the one closest in meaning to USE_THUMB, AFAICS) ? > > If the latter, then probably COMPILE_IN_THUMB_MODE is not that good a name. > It's long. Probably, in this case, USE_THUMB would be a good name, indeed.
Bad clipping on my end. Yes, I ment USE_THUMB instead of COMPILE_IN_THUMB_MODE. _______________________________________________ uClibc mailing list [email protected] http://lists.busybox.net/mailman/listinfo/uclibc
