On Tuesday, July 12, 2011 15:03:43 Yann E. MORIN wrote:
> On Tuesday 12 July 2011 20:04:36 Bernhard Reutner-Fischer wrote:
> > On Jul 9, 2011 8:50 PM, "Yann E. MORIN":
> > >  - this selects: HAS_THUMB, COMPILE_IN_THUMB_MODE and USE_BX
> > 
> > I would prefer to name the knob USE_THUMB instead.
> > Comments?
> 
> I am not a native english-speaker, but to me, USE_THUMB does not convey
> the important meaning that Thumb mode is forced; it is not as strong.
> Really, I named it thus to highlight the fact that some other config
> option did force Thumb to be used.

"USE_XXX" means "build code to actually use feature XXX".  "HAS_XXX" means 
"the processor has support for feature XXX", but that doesnt necessarily mean 
that the user wants to support it.
-mike

Attachment: signature.asc
Description: This is a digitally signed message part.

_______________________________________________
uClibc mailing list
[email protected]
http://lists.busybox.net/mailman/listinfo/uclibc

Reply via email to