Clint,
Thanks, those instructions did the trick.
A few years ago with your help and those of others here in this group, I 
created my first real Windows GUI program.  I did such on a Windows 7 computer 
and tried recompiling that program today on my Ubuntu 16.04 system.  It fails 
to compile and I can't figure out why.
import gui$include "guih.icn"## To do# 1.  On saving home teachers and 
families, only save those which are not assigned to routes#
global dataStore, filef, fileht, filer, fromRoute, itemToBeMoved, 
procedureStore, routes
class Untitled : Dialog(panel_1, border_1, save_button, cancel_button, 
Route_1_Checkbox, Route_1_List, Route_1_label, Route_1_Families, 
Route_2_Checkbox, Route_2_List, Route_2_label, Route_2_Families, 
Route_3_Checkbox, Route_3_List, Route_3_label, Route_3_Families, 
Route_4_Checkbox, Route_4_List, Route_4_label, Route_4_Families, 
Route_5_Checkbox, Route_5_List, Route_5_label, Route_5_Families, 
Route_6_Checkbox, Route_6_List, Route_6_label, Route_6_Families, 
Route_7_Checkbox, Route_7_List, Route_7_label, Route_7_Families, 
Route_8_Checkbox, Route_8_List, Route_8_label, Route_8_Families, 
Route_9_Checkbox, Route_9_List, Route_9_label, Route_9_Families, 
Route_10_Checkbox, Route_10_List, Route_10_label, Route_10_Families, 
Route_11_Checkbox, Route_11_List, Route_11_label, Route_11_Families, 
Route_12_Checkbox, Route_12_List, Route_12_label, Route_12_Families, 
Route_13_Checkbox, Route_13_List, Route_13_label, Route_13_Families, 
Route_14_Checkbox, Route_14_List, Route_14_label, Route_14_Families, 
Route_15_Checkbox, Route_15_List, Route_15_label, Route_15_Families, 
Route_16_Checkbox, Route_16_List, Route_16_label, Route_16_Families, 
Route_17_Checkbox, Route_17_List, Route_17_label, Route_17_Families, 
Route_18_Checkbox, Route_18_List, Route_18_label, Route_18_Families, 
Route_19_Checkbox, Route_19_List, Route_19_label, Route_19_Families, 
Route_20_Checkbox, Route_20_List, Route_20_label, Route_20_Families, 
Route_21_Checkbox, Route_21_List, Route_21_label, Route_21_Families, 
Route_22_Checkbox, Route_22_List, Route_22_label, Route_22_Families, 
Route_23_Checkbox, Route_23_List, Route_23_label, Route_23_Families, 
Route_24_Checkbox, Route_24_List, Route_24_label, Route_24_Families, 
Route_25_Checkbox, Route_25_List, Route_25_label, Route_25_Families, 
Route_26_Checkbox, Route_26_List, Route_26_label, Route_26_Families, 
Route_27_Checkbox, Route_27_List, Route_27_label, Route_27_Families, 
Route_28_Checkbox, Route_28_List, Route_28_label, Route_28_Families, 
Route_29_Checkbox, Route_29_List, Route_29_label, Route_29_Families, 
Route_30_Checkbox, Route_30_List, Route_30_label, Route_30_Families, 
Route_31_Checkbox, Route_31_List, Route_31_label, Route_31_Families, 
Route_32_Checkbox, Route_32_List, Route_32_label, Route_32_Families, 
Route_33_Checkbox, Route_33_List, Route_33_label, Route_33_Families, 
Route_34_Checkbox, Route_34_List, Route_34_label, Route_34_Families, 
Route_35_Checkbox, Route_35_List, Route_35_label, Route_35_Families, 
Route_36_Checkbox, Route_36_List, Route_36_label, Route_36_Families)
...
---
steve@steve-Satellite-L555D:~/Desktop/HT$ icont 
ht.icnTranslating:ht.icn:ht.icn:1: # "import": invalid declarationht.icn:8: # 
";": invalid declaration  main  copyFile  getSelection  handleAllHomeTeachers  
handleFamily  handleHomeTeacher  labelToList  LoadTable  makeRouteLabel  
makeSelectionList  printReport  putSelection  removeDistrict  
repaintSelectionList  SaveData  saveTable  sortedList  toInternalIndex2 errors
---
steve@steve-Satellite-L555D:~/Desktop/HT$ unicon ht.icnFile ht.icn; Line 2 # 
$include: cannot open "guih.icn"
steve@steve-Satellite-L555D:~/Desktop/HT$

      From: "Jeffery, Clint (jeffe...@uidaho.edu)" <jeffe...@uidaho.edu>
 To: Unicon Group <unicon-group@lists.sourceforge.net>; Steve Graham 
<jsgraha...@yahoo.com> 
 Sent: Thursday, September 15, 2016 5:41 PM
 Subject: Re: [Unicon-group] Unable to build from Alpha 13.0
   
#yiv8453922257 #yiv8453922257 -- P 
{margin-top:0;margin-bottom:0;}#yiv8453922257 Hi Steve,
It sounds like you've got your path problem sorted out for an existing session 
by manually setting it, but you still want a path solution that will work 
automatically for each shell session in future.  You know, UNIX is a wonderful 
thing, and one of thewonderful parts is that it has so many shells with 
different initialization files.  For example, you set your path in .profile, 
butyou don't mention what your shell is.  Maybe you needed to set it in .bashrc 
instead of .profile.  Or maybe you needed to setit in .cshrc, with different 
syntax.  And you probably already know that after adding Unicon to your path in 
one of these files,you have to either reboot, or re-login, or at least run the 
"source" command, in order for your change to take effect.

If I am walking into a generic UNIX and don't know what shell I am running, I 
run "ps" and it typically lists what shell process is executing. That tells me 
then, which initialization file and which syntax I have to use to modify my 
path.  For example, on my current Linux, I am running bash.  ~/.profile did 
work to add unicon to its PATH, but I did have to "source ~/.profile" or else 
re-login in order for the change to take effect.
Cheers,Clint
From: Steve Graham <jsgraha...@yahoo.com>
Sent: Thursday, September 15, 2016 4:49:22 PM
To: Unicon Group
Subject: Re: [Unicon-group] Unable to build from Alpha 13.0 I downloaded the 
file from http://unicon.org/dist/uni.zip
steve@steve-Satellite-L555D:/opt/unicon/bin$ ./unicon -featuresUnicon Version 
13.0 alpha.  Oct 1, 2015UNIXPOSIXDBMASCIIco-expressionsdynamic 
loadingenvironment variablesevent monitoringexternal functionskeyboard 
functionslarge integersmultiple programspattern typepipespseudo terminalssystem 
functionmessaginggraphicsX Windowslibz file compressionJPEG imagesPNG 
imagesCCompiler gcc 5.4.0Physical memory: 3878723584 bytesRevision Arch 
x86_64CPU cores 2Binaries at 
/opt/unicon/bin/steve@steve-Satellite-L555D:/opt/unicon/bin$ 
I tried adding /opt/unicon/bin to /etc/profile and ~/.profile, but the PATH was 
unchanged when starting up a new terminal.
When adding them to the PATH of an existing terminal, I am able to start ui and 
within ui am able to compile and run the program (only if it ends in .icn 
though).

Thanks, Steve
From: Jafar Al-Gharaibeh <to.ja...@gmail.com>
To: Steve Graham <jsgraha...@yahoo.com>
Cc: "Jeffery, Clint (jeffe...@uidaho.edu)" <jeffe...@uidaho.edu>; Unicon Group 
<unicon-group@lists.sourceforge.net>
Sent: Thursday, September 15, 2016 3:04 PM
Subject: Re: [Unicon-group] Unable to build from Alpha 13.0

Hello Steve,
    Are you building off svn checkout? or downloading the zipped sources 
fromunicon.org?     "unicon -features" tells you which revision you have 
exactly. That might be useful when reporting a problem.
    I tested ui and didn't and it worked with a hello world program. However 
the lines "Script started... Script done" lines seems to be something that 
shouldn't be there, I don't remember seeing them before.
Do you have "/opt/unicon/bin/" in your path?
--Jafar
 
On Thu, Sep 15, 2016 at 1:31 PM Steve Graham <jsgraha...@yahoo.com> wrote:

Another question on setup.
I downloaded and compiled Unicon again on the same system.  After remembering 
to make the change to Makedefs, it worked fine.  I placed the unicon directory 
in /opt.
I'm having trouble compiling from ui:
steve@steve-Satellite-L555D:/opt/unicon/bin$ ./ui <-- Brings up ui

Typing in the Hello Amigo program I select Run/Run, which results in a terminal 
window coming up which says:
Script started, file is /tmp/ui17730737.tmpbash: ./Hello-Amigo: No such file or 
directoryScript done, file is /tmp/ui17730737.tmp
steve@steve-Satellite-L555D:/tmp$ cat ui17730737.tmp Script started on Thu 15 
Sep 2016 11:22:37 AM PDTbash: ./Hello-Amigo: No such file or directory
Script done on Thu 15 Sep 2016 11:22:37 AM PDTsteve@steve-Satellite-L555D:/tmp$
What am I doing wrong here?

Thanks, Steve
From: Jafar Al-Gharaibeh <to.ja...@gmail.com>
To: Steve Graham <jsgraha...@yahoo.com>
Cc: "Jeffery, Clint (jeffe...@uidaho.edu)" <jeffe...@uidaho.edu>; Unicon Group 
<unicon-group@lists.sourceforge.net>
Sent: Monday, August 15, 2016 12:31 PM
Subject: Re: [Unicon-group] Unable to build from Alpha 13.0

Steve,
Thanks for the update. Not sure why you had the problem the first time. Maybe 
something went wrong during initialization/configuration. I also have see 
anonymous svn checkout/update to be unreliable/out-of-date in some rare 
occasions. I'm glad we got it sorted out anyway.
Cheers,JafarOn Mon, Aug 15, 2016 at 11:59 AM, Steve Graham 
<jsgraha...@yahoo.com> wrote:

Clint:  Thanks for the suggestions.
Jafar:Your suggestions proved to be the solution.  Here is a compare between 
the original Makedefs and the generated one


steve@steve-Satellite-L555D:/ opt/unicon$ diff Makedefs.old Makedefs

25c25< RLIBS = $(LIBS) -L../../bin -lm -lgdbm -ltp -lnsl -ldl -lcrypt---> RLIBS 
= -ltp $(LIBS) -L../../bin -lm -lgdbm -lnsl -ldl 
-lcryptsteve@steve-Satellite-L555D:/ opt/unicon$ 
Not sure why the original one gave me problems because I got everything last 
week from the svn site.

Thanks, Steve

From: Jafar Al-Gharaibeh <to.ja...@gmail.com>
To: "Jeffery, Clint (jeffe...@uidaho.edu)" <jeffe...@uidaho.edu>
Cc: Steve Graham <jsgraha...@yahoo.com>
Sent: Thursday, August 11, 2016 8:16 AM
Subject: Re: [Unicon-group] Unable to build from Alpha 13.0

Steve,
Just to make sure we get this properly fixed, I looked at my Makedef to see the 
order of the libraries. I have these lines:
AC_LIBS= -lcrypto -lssl -lpthread -lGLU -lGL -lpng -ljpeg -lX11 -lz -lcrypt 
-lnsl
LIBS = -L/usr/lib64 $(AC_JV_LDFLAGS) $(AC_GL_LDFLAGS) $(AC_LIBS) -lm

RLIBS = -ltp $(LIBS) -L../../bin -lm -lgdbm -lnsl -ldl -lcrypt

RLIBS is what eventually used at the link line, and as you can see we 
specifically placed -ltp before LIBS. I remember doing this a while back, not 
sure if the change was triggered by ssl or another library. This change has 
been in svn for a long time. The template for x86_64_linux Makedef file is 
under unicon/config/x86_64_linux/ Makedfes.
Is there a chance your Makedefs template is out of date? I suggest you do "svn 
up" at the top level Unicon directory and see if you get new stuff.
Cheers,Jafar

On Thu, Aug 11, 2016 at 12:26 AM Jafar Al-Gharaibeh <to.ja...@gmail.com> wrote:


For some reason my gmail's spam filter got all  Steve's emails, I got confused 
when I got the email from Clint! :) sorry I didn't help earlier. 
 From glancing through your logs and without trying on my end, I suspect the 
problem is in the order of libraries at the link line. Specially -lss should 
probably come after -ltp, and maybe the same goes for -lcrypto. After you 
configure, please edit your Unicon/Makedefs file to make the change, and 
proceed to build as usual.

Sorry Again!Jafar 
On Wed, Aug 10, 2016 at 7:50 PM, Jeffery, Clint 
(jeffe...@uidaho.edu)<jeffe...@uidaho.edu> wrote:

Steve,
Thanks, the extra details are necessary for us to figure out why your Unicon 
isn't building OK.  To be honest, debugging at this level of detail is probably 
not that entertaining and we should take it off of unicon-group. However, if we 
learn something of general interest, we can post back about it.
Your next step is to tell me exactly what libssl you got, from where or using 
what command, so I can try to apply the same packages to my Ubuntu machine. 
Your best hope for a quick resolution is for either myself or Jafar to be able 
to reproduce your trouble.
I also will want to know the value of your LD_LIBRARY_PATH environment variable 
if any, and the output of "nm" for whatever version of libssl you are linking 
in with the -lssl command. When autoconf finds a viable libssl and tells the 
make command to link it in, the same link that causes the test to pass would 
normally cause the symbols that are undefined to be included in your iconx, so 
it is a puzzler.
Cheers,Clint

From: Steve Graham <jsgraha...@yahoo.com>
Sent: Wednesday, August 10, 2016 2:10 PM
To: Jeffery, Clint (jeffe...@uidaho.edu); Unicon Group
Subject: Re: [Unicon-group] Unable to build from Alpha 13.0 Here is the log 
from my attempt at building Unicon:

------------------------------ ------------------------------ ------------------
What NetFlow Analyzer can do for you? Monitors network bandwidth and traffic
patterns at an interface-level. Reveals which users, apps, and protocols are
consuming the most bandwidth. Provides multi-vendor support for NetFlow,
J-Flow, sFlow and other flows. Make informed decisions using capacity
planning reports. http://sdm.link/zohodev2dev
______________________________ _________________
Unicon-group mailing list
Unicon-group@lists. sourceforge.net
https://lists.sourceforge.net/ lists/listinfo/unicon-group




-- 
-- Sent From My Smartphone



-- 
-- Sent From My Smartphone



   
------------------------------------------------------------------------------
_______________________________________________
Unicon-group mailing list
Unicon-group@lists.sourceforge.net
https://lists.sourceforge.net/lists/listinfo/unicon-group

Reply via email to