Is anyone using Apache Beam with Kafka 0.9.x and older?

I am thinking of deprecating 0.9.x and 0.10.0 in Beam 2.4 and remove
support in 2.5 or later. 0.10.1 and up will be supported. 0.10.1+ includes
much better timestamp support.

By deprecation I mean KafkaIO would continue to work with an older version
at runtime, but would not build with it (e.g. `mvn
-Dkafka.clients.version=0.9.1` fails).  We can print a deprecation warning
at runtime.


Reply via email to