There wouldn't be new Kafka 0.9.x release.

+1 on dropping support for 0.9.x

On Fri, Feb 2, 2018 at 4:12 PM, Raghu Angadi <rang...@google.com> wrote:

> Is anyone using Apache Beam with Kafka 0.9.x and older?
>
> I am thinking of deprecating 0.9.x and 0.10.0 in Beam 2.4 and remove
> support in 2.5 or later. 0.10.1 and up will be supported. 0.10.1+ includes
> much better timestamp support.
>
> By deprecation I mean KafkaIO would continue to work with an older version
> at runtime, but would not build with it (e.g. `mvn
> -Dkafka.clients.version=0.9.1` fails).  We can print a deprecation warning
> at runtime.
>
> [1]: https://github.com/apache/kafka/commit/23c69d62a0cabf06c4db8b338f0ca8
> 24dc6d81a7
>

Reply via email to