Awesome, that did the trick!

I had to remove the TcpDiscoveryVmIpFinder because it was complaining:
org.apache.ignite.spi.IgniteSpiException: Local node's marshaller differs
from remote node's marshaller (to make sure all nodes in topology have
identical marshaller, configure marshaller explicitly in configuration)
locNodeAddrs=[,, /, /], locPort=48500, rmtNodeAddr=[,, /, /], locNodeId=9efb532c-1c12-4f7f-b35f-e7549ea22d78,

But I replaced it the multicast ip finder and it worked.

On Fri, Oct 14, 2016 at 2:28 PM, vkulichenko [via Apache Ignite Users] <> wrote:

> Hi,
> Please properly subscribe to the mailing list so that the community can
> receive email notifications for your messages. To subscribe, send empty
> email to and follow simple instructions
> in the reply.
> msimonsen wrote
> Hello.
> I believe that there is an issue with the Hibernate integration.  I am
> testing with ignite 1.7.0 - although I see no relevant recent updates in
> the ignite-hibernate module.
> There are no issues with respect to single node ignite cluster, I only
> noticed this issue with *multiple nodes*.
> I have a REPLICATED, Hibernate L2 cache that is declared as such:
>  <bean parent="transactional-cache">
>                         <property name="name" value="com.ethoca.db.gen.
> Member"/>
>                     </bean>
> <bean id="transactional-cache" 
> class="org.apache.ignite.configuration.CacheConfiguration"
> abstract="true">
>             <property name="cacheMode" value="PARTITIONED"/>
>             <property name="atomicityMode" value="TRANSACTIONAL"/>
>             <property name="writeSynchronizationMode" value="FULL_SYNC"/>
>         </bean>
> The beans are annotated, but I have also explicitly set caching the the
> hibernate configuration with the same result.
> The main issue is that cache is not properly reflected with any given
> member primary key query when executed from another ignite instance/node.
> Hibernate does not recognize the member has been cached and hits the
> database, registering it in L2 statistics as a miss.
> I can also demonstrate that at runtime, with a write through of the same
> entity that the cache is not getting updated in other nodes - essentially
> it's a local, non-replicated cache.
> I've gone through the example and shown that within a single node (and
> single SessionFactory) instance that things are working fine (read/write
> through, etc), however when I add an additional node things are not fine.
> Please let me know if you need me to clarify anything!
> This is a known issue, see the note about binary format here:
> cache-configuration
> -Val
> ------------------------------
> If you reply to this email, your message will be added to the discussion
> below:
> L2-Issue-tp8298p8299.html
> To unsubscribe from Hibernate L2 Issue, click here
> <>
> .
> <>

View this message in context:
Sent from the Apache Ignite Users mailing list archive at

Reply via email to