Ed Avis wrote:
> Davide Bianchi <davide <at> walterisookeensufferukker.nl> writes:
>
>>> I don't know what the extra '?cn?sub' at the end of the query string is for
>> "cn" means that the attibute to use to login is the CN = common name,
Heeemmmm... sorry (not enough coffee in my bloodstream), that is the
attribute that is returned
Definition taken from RFC1959
<ldapurl> ::= "ldap://" [ <hostport> ] "/" <dn> [ "?" <attributes>
[ "?" <scope> "?" <filter> ] ]
<hostport> ::= <hostname> [ ":" <portnumber> ]
<dn> ::= a string as defined in RFC 1485
<attributes> ::= NULL | <attributelist>
<attributelist> ::= <attributetype>
| <attributetype> [ "," <attributelist> ]
<attributetype> ::= a string as defined in RFC 1777
<scope> ::= "base" | "one" | "sub"
<filter> ::= a string as defined in RFC 1558
Explanations:
DN
Distinguished name
Attribute list
List of attributes you want returned
Scope
base = base object search
one = one level search
sub = subtree search
--
A fool and his money are soon using Windows.
---------------------------------------------------------------------
The official User-To-User support forum of the Apache HTTP Server Project.
See <URL:http://httpd.apache.org/userslist.html> for more info.
To unsubscribe, e-mail: [email protected]
" from the digest: [email protected]
For additional commands, e-mail: [email protected]