On 09/15/16 15:48, François Patte wrote:
> Le 14/09/2016 23:56, Ed Greshko a écrit :
>> On 09/14/16 23:39, François Patte wrote:
>>> Thanks for answering. No errors in the log file. I tried to load the
>>> nvidia module using modprobe and the answer was the same: FATAL module
>>> nvidia not found (while it is in the right directory)....
>>> So I run depmod -a and the problem is solved, but this does not explain
>>> why akmod did not run (or failed to run) depmod after building the module.
>> In addition to what others have said, make sure you have both 
>> akmods-shutdown.service and
>> akmods.service enabled.  
> Both are enabled. I suppose that it is the default state when you
> install akmods...
>> I've found that having both enabled will catch improperly
>> installed kmods.
> So? Do we have to disable one of them? And which one?

Ahhh....  I said "make sure you have both" enabled and I did mean *both*.  So, 
I can't see
why I would be seen as advocating to disable one.

Anyway, to repeat, there is no indication they are "running" and doing the 
needed depmod
along the way.  So, it is possible (and I've done it) to mess things up beyond 
ability to recover.  I don't know if that is what happened in your case....but 
since the
solution for you was was to manually run "depmod -a" I would think it is a 

You're Welcome Zachary Quinto

Attachment: signature.asc
Description: OpenPGP digital signature

users mailing list
To unsubscribe or change subscription options:
Fedora Code of Conduct: http://fedoraproject.org/code-of-conduct
Guidelines: http://fedoraproject.org/wiki/Mailing_list_guidelines
Have a question? Ask away: http://ask.fedoraproject.org

Reply via email to