On Thu, 1 Dec 2016, Howard Howell wrote:

Hi, guys,
        After googling this issue on upgrading fedora, working until
2:30 this morning, and not getting anywhere, I hope you guys can help.

        I followed the guide:
https://fedoramagazine.org/upgrading-fedora-24-fedora-25/
        using the gnome terminal.
        things seemed to go well, until I got to the command

        # dnf system-upgrade download --releasever=25

        It went through the usual steps, I answered y and it completed,
but then it prompted me with an error message about google earth and
said to retry with --allowerasing, which I did, but still got the same
error message:
        warning: /var/lib/dnf/system-upgrade/google-earth-stable-
6.0.3.2197-0.x86_64.rpm: Header V4 DSA/SHA1 Signature, key ID 7fac5991:
NOKEY
The downloaded packages were saved in cache until the next successful
transaction.
You can remove cached packages by executing 'dnf clean packages'.
Error: Public key for google-earth-stable-6.0.3.2197-0.x86_64.rpm is
not installed

        So I did a gpg install for the public key of google-earth.
        Same error message.
        just to try I did:
        #dnf system-upgrade reboot

        No joy.  Spent several hours googling for the error, for the
issue with gpg key, various other related lookups, but didn't find
anything that helped.  

        So!! Help!!!!

I had the same problem. Since it has been a week or so, and memory is getting creaky ...

There is a new version of Google Earth (ver 7?, someone help me). It doesn't use the google-earth.repo

So, I removed/backup up the google-earth.repo from /etc/yum.repos.d/ directory.

dnf removed google-earth-stable (I think that's the right name)

and!

went into the /var/lib/dnf/system-upgrade (I think) and rm'd the google-earth package that was sitting there.

From memory, that's what worked for me (but YMMV)

Once the upgrade completed, and everything seemed to be functioning correctly, I then did a dnf install <Path/And/Name/Of/google-earth-stable> package that I downloaded from the Google Earth page.


Regards,
Les H


Max Pyziur
p...@brama.com
_______________________________________________
users mailing list -- users@lists.fedoraproject.org
To unsubscribe send an email to users-le...@lists.fedoraproject.org

Reply via email to