I see,
Where can i find the 2.6.3 version ? I don't have it installed. I do have a folder /Library/Frameworks/Mono.framework/Versions/2.6.3/etc/ but that's it. I can't seem to download it from the mono-project website.
Thanks for the help !

On 17/05/2010 14:10, Laurent Etiemble wrote:

I just noticed that the pkg-config results differs between 2.6.3 and 2.6.4:

- In 2.6.3:
pkg-config --cflags mono => "-D_THREAD_SAFE -D_REENTRANT -I/Library/Frameworks/Mono.framework/Versions/2.6.3/include/mono-1.0 -I/Library/Frameworks/Mono.framework/Versions/2.6.3/include/glib-2.0 -I/Library/Frameworks/Mono.framework/Versions/2.6.3/lib/glib-2.0/include "

- In 2.6.4:
pkg-config --cflags mono => "-D_THREAD_SAFE -I/Library/Frameworks/Mono.framework/Versions/2.6.4/include/mono-1.0 "

The pkg-config file for Mono is wrong in Mono 2.6.4, as Mono stills depends on the GLib when performing the embedding (see metadata/assembly.h for example).

A quick fix is to copy the mono.pc from a 2.6.3 install to the 2.6.4 install. It is located in "/Library/Frameworks/Mono.framework/Versions/2.6.3/lib/pkgconfig/mono.pc"

Regards, Laurent Etiemble.

2010/5/17 Mario De Clippeleir <mari...@sydec.be <mailto:mari...@sydec.be>>

    On 13/05/2010 14:21, Laurent Etiemble wrote:

    My answers below:

    Regards, Laurent Etiemble.

    2010/5/12 Mario De Clippeleir <mari...@sydec.be


        I was trying this debugger but i stumbled upon the following
        error when starting debug:

        Unhandled Exception: Monobjc.ObjectiveCException: The
        'libmonobjc.2.dylib' library was not found. Please check that
        you have correctly installed it. --->
        System.DllNotFoundException: @executable_path/libmonobjc.2.dylib
          at (wrapper managed-to-native)
        () [0x00000] in <filename unknown>:0
          --- End of inner exception stack trace ---
        () [0x00000] in <filename unknown>:0
          at Monobjc.Runtime.RuntimeBridge.get_Current () [0x00000]
        in <filename unknown>:0
          at (wrapper synchronized)
        Monobjc.Runtime.RuntimeBridge:get_Current ()
          at Monobjc.ObjectiveCRuntime.DefineClass (System.Type type)
        [0x00000] in <filename unknown>:0
          at Monobjc.ObjectiveCRuntime.ScanAssembly
        (System.Reflection.Assembly assembly) [0x00000] in <filename

        What am i missing here ?

    Have you installed Monobjc in the GAC ? There is a script called
    "GacInstall.sh" at the root of the all-in-one archive for that.
    Yes I have.... I ran under the unzipped monobjc folder. However my
    libs are in the lib folder of my application, does that matter ?

        Also : When i am trying to mkbundle my appl on snow leopard i
        am getting all sorts of error messages and the mac executable
        does not seem to get build. The errors are all of the
        following form :
        error: glib.h: No such file or directory
         [mkbundle] In file included from
        error: stdio.h: No such file or directory
         [mkbundle] In file included from

        error: expected '=', ',', ';', 'asm' or '__attribute__'
        before 'typedef'
        error: expected ':', ',', ';', '}' or '__attribute__' before
        '*' token
        error: expected '=', ',', ';', 'asm' or '__attribute__'
        before '*' token
        error: expected '=', ',', ';', 'asm' or '__attribute__'
        before '*' token
        error: expected '=', ',', ';', 'asm' or '__attribute__'
        before '*' token

        Any ideas ? I did a clean install of my dev environment, so i
        am gessing i have forgotten something....

    Have you installed the Mono CSDK ? Can you run the NAnt script
    with the "-v+" switch to have more logs ?
    The CSDK is installed. (as well as the framework, otherwise i
    can't run monodevelop). I have re-installed the CSDK just to make
    sure. The verbose option with nant does not give more information...
    I don't understand what is going on here. It always worked fine
    for me, so it must be that I have forgotten something (really
    stupid probably)....


        On 16 Mar 2010, at 14:40, Laurent Etiemble wrote:


        A MonoDevelop integration is now available:

        Regards, Laurent Etiemble.

        2010/1/9 Rufus Buschart <rufus.busch...@gmail.com


            I would like to ask you, what you recommend as the most
            simplest way to debug C#/mono using the Monobjc library.
            After some long hours I found out, that I'm able to
            compile Monobjc applications from within Monodevelop.
            Also I found out that these application even run, if you
            structure the output as an application bundle and start
            the bundle from the Finder or from Terminal. But every
            time when I try to execute them with the integrated
            debugger of Monodevelop I get the "Error loading
            NIB"-Message, which is discussed a couple of times in
            the archive of this mailing list.

            So how do you debug your applications?

            Maybe we get this "Error loading NIB"-problem fixed, if
            we set some parameter correctly? I would love to get the
            integrated debugger of Monodevelop working with Monobjc.

            I'm fairly new to Monobjc and developing in Cocoa but I
            do have 5+ years of professional development background
            in .net/C# under Windows.

            Best regards,


            What we do in life, echoes in eternity.
            Rufus J.W. Buschart  ICQ#: 47136206
            Kirchenstr. 8 http://www.buschart.de
            91054 Erlangen
            Phone: +49 (0)9131 - 530 15 85
            Mobile: +49 (0)176 - 701 800 81
Sent from Nuremberg, BY, Deutschland

Reply via email to