Hi Ben,

Could you check if a 2.3 version prior this commit:
https://github.com/OpenSIPS/opensips/commit/f25fbf631b6fb6eafea192f95f9a43566d68cc46#diff-91bbef43b346f11cbef768a1b01c74e0
will still have the 1.11 behavior?

Regards,

Bogdan-Andrei Iancu

OpenSIPS Founder and Developer
  http://www.opensips-solutions.com
OpenSIPS Summit 2018
  http://www.opensips.org/events/Summit-2018Amsterdam

On 02/15/2018 03:22 PM, Ben Newlin wrote:

Bogdan,

Yes, this exact configuration was working in 1.11. None of these module required any configuration changes that I could see for the migration, so it is unchanged.

Thanks,

Ben Newlin

*From: *Bogdan-Andrei Iancu <bog...@opensips.org>
*Date: *Thursday, February 15, 2018 at 2:21 AM
*To: *OpenSIPS users mailling list <users@lists.opensips.org>, Ben Newlin <ben.new...@genesys.com>
*Subject: *Re: [OpenSIPS-Users] Avpops and db_virtual modules

Ben, emails are welcome, as they provide valuable feedback for us ;)

Do you say that avpops + db_virtual combination was working in 1.11 ? I remember there were some fixes couple of months ago in regards to how the capabilities do propagate via the virtual module.

Regards,

Bogdan-Andrei Iancu
OpenSIPS Founder and Developer
http://www.opensips-solutions.com
OpenSIPS Summit 2018
http://www.opensips.org/events/Summit-2018Amsterdam

On 02/15/2018 02:36 AM, Ben Newlin wrote:

    Hi,

    Sorry for all of the emails! I have found one more issue while
    trying to upgrade from OpenSIPS 1.11 to 2.x. We use the db_virtual
    module in front of our redundant Postgres DB instances to
    facilitate failover between the DBs. We also use the avpops module
    to perform raw queries against the DB. In both 2.2.6 and 2.3.3 I
    get the following error when trying to load this configuration:

    CRITICAL:avpops:avpops_db_bind: database modules (virtual://set1)
    does not provide all functions needed by avpops module

    ERROR:core:init_mod: failed to initialize module avpops

    My configuration is as follows:

    #// PostgreSQL Database module

    loadmodule "db_postgres.so"

    modparam("db_postgres", "exec_query_threshold", 500000)

    #// Virtual DB module

    loadmodule "db_virtual.so"

    modparam("db_virtual", "db_urls", "define set1 ROUND")

    modparam("db_virtual", "db_urls",
    
"postgres://postgres:postgres@127.0.0.1:5432/postgres"<mailto:postgres://postgres:postgres@127.0.0.1:5432/postgres>)

    #//  AVP OPerationS module

    loadmodule "avpops.so"

    modparam("avpops", "db_url", "virtual://set1")

    Is db_virtual simply not compatible with the new OpenSIPS versions
    or has something changed in the configuration that I am missing?

    Thanks,

    Ben Newlin




    _______________________________________________

    Users mailing list

    Users@lists.opensips.org<mailto:Users@lists.opensips.org>

    http://lists.opensips.org/cgi-bin/mailman/listinfo/users




_______________________________________________
Users mailing list
Users@lists.opensips.org
http://lists.opensips.org/cgi-bin/mailman/listinfo/users

Reply via email to