Thanks Andy for replying.

maven dependency:tree -Dverbose does not seem to work for me. It gives me
the below message

...
[INFO] --- maven-dependency-plugin:3.1.1:tree (default-cli) @ delete ---
[INFO] Verbose not supported since maven-dependency-plugin 3.0
[INFO] com.vnera:delete:jar:0.001-SNAPSHOT
...

If I just exclude netty-common from apache-bookkeeper then netty-common
4.1.32 does not show up in the dependency tree.


On Sat, May 23, 2020 at 3:57 AM Andy Feldman <an...@wealthfront.com> wrote:

> On Fri, May 22, 2020 at 6:31 AM Debraj Manna <subharaj.ma...@gmail.com>
> wrote:
>
> > bookkeeper-common is in test scope but still netty-common is showing up
> as
> > compile dependency.
> >
>
> Is it possible that netty-common is a transitive dependency of another
> dependency as well? Running dependency:tree does not show all paths to each
> dependency.
>
> You can try running dependency:tree with the verbose flag to see more
> branches of the tree, although the documentation says it is not guaranteed
> to work properly with Maven 3.
>
> https://maven.apache.org/plugins/maven-dependency-plugin/tree-mojo.html#verbose
>
> You can also try removing the dependency on bookkeeper-common and running
> dependency:tree again to see if netty-common still shows up.
>
> --
> Andy Feldman
> Wealthfront
>

Reply via email to