On Thu, Dec 10, 2015 at 6:34 PM, Simone Tiraboschi <stira...@redhat.com>
wrote:

>
>
> On Thu, Dec 10, 2015 at 6:24 PM, wodel youchi <wodel.you...@gmail.com>
> wrote:
>
>> Hi,
>>
>> Yes I tried to refresh many time the Webgui, even logging out and logging
>> in again, but no changes.
>>
>> here is the engine-setup logs
>>
>> the big one, is the log of the first setup.
>>
>
> Ok, the engine update issue is here:
> 2015-12-10 12:48:20 DEBUG otopi.ovirt_engine_setup.engine_common.database
> database.execute:214 Result: [{'started_at': datetime.datetime(2015, 12,
> 10, 11, 24, 20, 316000, tzinfo=psycopg2.tz.FixedOffsetTimezone(offset=60,
> name=None)), 'task_id': 'fd62d708-8e9c-4209-956c-3bfc627b3117',
> 'action_type': 36, 'name': 'Default'}]
> 2015-12-10 12:48:20 DEBUG otopi.context context._executeMethod:152 method
> exception
> Traceback (most recent call last):
>   File "/usr/lib/python2.7/site-packages/otopi/context.py", line 142, in
> _executeMethod
>     method['method']()
>   File
> "/usr/share/ovirt-engine/setup/bin/../plugins/ovirt-engine-setup/ovirt-engine/upgrade/asynctasks.py",
> line 448, in _validateAsyncTasks
>     ) = self._checkRunningTasks()
>   File
> "/usr/share/ovirt-engine/setup/bin/../plugins/ovirt-engine-setup/ovirt-engine/upgrade/asynctasks.py",
> line 341, in _checkRunningTasks
>     self._getRunningTasks(dbstatement),
>   File
> "/usr/share/ovirt-engine/setup/bin/../plugins/ovirt-engine-setup/ovirt-engine/upgrade/asynctasks.py",
> line 202, in _getRunningTasks
>     for entry in tasks
> KeyError: '36'
> 2015-12-10 12:48:20 ERROR otopi.context context._executeMethod:161 Failed
> to execute stage 'Setup validation': '36'
>
> You tried to run engine-setup while an async task was running; the task
> was of kind  36 and engine-setup tried to decode it but it failed cause it
> doesn't know about that task type.
> If you simply retry after that task has been completed it will succeed.
>
> It's still worth to open a bug against that so I'll do.
>

https://bugzilla.redhat.com/show_bug.cgi?id=1290528


>
>
> As I said you don't need to update the engine to refresh the engine VM
> details so it's worth to investigate also that one.
> Can you please attach also vdsm logs?
>
>
>
>
>> the small one, is from today's setup after augmenting the amount of
>> memory for the HE.
>>
>> Thanks
>>
>> <https://www.avast.com/?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=webmail>
>>  Cet
>> e-mail a été envoyé depuis un ordinateur protégé par Avast.
>> www.avast.com
>> <https://www.avast.com/?utm_medium=email&utm_source=link&utm_campaign=sig-email&utm_content=webmail>
>> <#1518cf5bb43d38e5_1518cec58a732f51_DDB4FAA8-2DD7-40BB-A1B8-4E2AA1F9FDF2>
>>
>> 2015-12-10 15:15 GMT+01:00 Simone Tiraboschi <stira...@redhat.com>:
>>
>>>
>>>
>>> On Thu, Dec 10, 2015 at 12:53 PM, wodel youchi <wodel.you...@gmail.com>
>>> wrote:
>>>
>>>> Hi,
>>>>
>>>> I have an oVirt 3.5.6 platform using hosted-engine setup.
>>>>
>>>> I installed my engine's VM with 2Gb of memory at the beginning, now I
>>>> want to add 2Gb
>>>>
>>>> I've modified /etc/ovirt-hosted-engine/vm.conf on my hypervisors
>>>>
>>>
>>> On 3.5 it was enough. On 3.6.z you will be able to edit from the engine
>>> web ui.
>>>
>>>
>>>>
>>>> the VM is booting with 4Gb of memory (free -m), but the GUI is still
>>>> showing 2Gb
>>>>
>>>
>>> Did you tried to refresh?
>>>
>>>
>>>>
>>>> I tried engine-setup but I get this error
>>>>
>>>>
>>> It's absolutely not needed but on the other side it shouldn't fail as
>>> well.
>>> Can you please attach the whole engine-setup logs?
>>>
>>>
>>>>
>>>> [ INFO  ] Cleaning async tasks and compensations
>>>> [ ERROR ] Failed to execute stage 'Setup validation': '36'
>>>> [ INFO  ] Stage: Clean up
>>>>           Log file is located at
>>>> /var/log/ovirt-engine/setup/ovirt-engine-setup-20151210124227-xrr3g5.log
>>>> [ INFO  ] Generating answer file
>>>> '/var/lib/ovirt-engine/setup/answers/20151210124820-setup.conf'
>>>> [ INFO  ] Stage: Pre-termination
>>>> [ INFO  ] Stage: Termination
>>>> [ ERROR ] Execution of setup failed
>>>>
>>>>
>>>> Here is the tailf log
>>>>
>>>> 2015-12-10 12:48:20 DEBUG otopi.context context.dumpEnvironment:500 ENV
>>>> OVESETUP_WSP_RPMDISRO_PACKAGES_SETUP=str:'ovirt-engine-setup-plugin-websocket-proxy'
>>>> 2015-12-10 12:48:20 DEBUG otopi.context context.dumpEnvironment:500 ENV
>>>> PACKAGER/keepAliveInterval=int:'30'
>>>> 2015-12-10 12:48:20 DEBUG otopi.context context.dumpEnvironment:500 ENV
>>>> PACKAGER/yumDisabledPlugins=list:'[]'
>>>> 2015-12-10 12:48:20 DEBUG otopi.context context.dumpEnvironment:500 ENV
>>>> PACKAGER/yumEnabledPlugins=list:'[]'
>>>> 2015-12-10 12:48:20 DEBUG otopi.context context.dumpEnvironment:500 ENV
>>>> PACKAGER/yumExpireCache=bool:'True'
>>>> 2015-12-10 12:48:20 DEBUG otopi.context context.dumpEnvironment:500 ENV
>>>> PACKAGER/yumRollback=bool:'True'
>>>> 2015-12-10 12:48:20 DEBUG otopi.context context.dumpEnvironment:500 ENV
>>>> PACKAGER/yumpackagerEnabled=bool:'True'
>>>> 2015-12-10 12:48:20 DEBUG otopi.context context.dumpEnvironment:500 ENV
>>>> SYSTEM/clockMaxGap=int:'5'
>>>> 2015-12-10 12:48:20 DEBUG otopi.context context.dumpEnvironment:500 ENV
>>>> SYSTEM/clockSet=bool:'False'
>>>> 2015-12-10 12:48:20 DEBUG otopi.context context.dumpEnvironment:500 ENV
>>>> SYSTEM/commandPath=str:'/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin'
>>>> 2015-12-10 12:48:20 DEBUG otopi.context context.dumpEnvironment:500 ENV
>>>> SYSTEM/reboot=bool:'False'
>>>> 2015-12-10 12:48:20 DEBUG otopi.context context.dumpEnvironment:500 ENV
>>>> SYSTEM/rebootAllow=bool:'True'
>>>> 2015-12-10 12:48:20 DEBUG otopi.context context.dumpEnvironment:500 ENV
>>>> SYSTEM/rebootDeferTime=int:'10'
>>>> 2015-12-10 12:48:20 DEBUG otopi.context context.dumpEnvironment:504
>>>> ENVIRONMENT DUMP - END
>>>> 2015-12-10 12:48:20 DEBUG otopi.context context._executeMethod:138
>>>> Stage pre-terminate METHOD
>>>> otopi.plugins.otopi.dialog.cli.Plugin._pre_terminate
>>>> 2015-12-10 12:48:20 DEBUG otopi.context context._executeMethod:144
>>>> condition False
>>>> 2015-12-10 12:48:20 INFO otopi.context context.runSequence:417 Stage:
>>>> Termination
>>>> 2015-12-10 12:48:20 DEBUG otopi.context context.runSequence:421 STAGE
>>>> terminate
>>>> 2015-12-10 12:48:20 DEBUG otopi.context context._executeMethod:138
>>>> Stage terminate METHOD
>>>> otopi.plugins.ovirt_engine_common.base.core.misc.Plugin._terminate
>>>> 2015-12-10 12:48:20 ERROR
>>>> otopi.plugins.ovirt_engine_common.base.core.misc misc._terminate:151
>>>> Execution of setup failed
>>>> 2015-12-10 12:48:20 DEBUG otopi.context context._executeMethod:138
>>>> Stage terminate METHOD otopi.plugins.otopi.dialog.human.Plugin._terminate
>>>> 2015-12-10 12:48:20 DEBUG otopi.context context._executeMethod:138
>>>> Stage terminate METHOD otopi.plugins.otopi.dialog.machine.Plugin._terminate
>>>> 2015-12-10 12:48:20 DEBUG otopi.context context._executeMethod:144
>>>> condition False
>>>> 2015-12-10 12:48:20 DEBUG otopi.context context._executeMethod:138
>>>> Stage terminate METHOD otopi.plugins.otopi.core.log.Plugin._terminate
>>>>
>>>>
>>>>
>>>>
>>>>
>>>> - What is the correct way to modify the engine's VM memory
>>>>
>>>>
>>>> Thanks in advance.
>>>>
>>>> _______________________________________________
>>>> Users mailing list
>>>> Users@ovirt.org
>>>> http://lists.ovirt.org/mailman/listinfo/users
>>>>
>>>>
>>>
>>
>
_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to