Before installing the oVirt Node I set the ifcfg-enp3s0 to a static address (no 
dhcp server availaible on this network).

After installing the Node through the oVirt interface I was still able to 
connect to the server using that address.
After reboot the IP was still active. After connecting the ovirtmgmt to that 
interface I saw that is was set to DHCP (but the static IP was filled in the 
grayed out boxes)  so probably something has gone wrong during the install of 
the VDSM package?


Van: Ido Barkan [mailto:ibar...@redhat.com]
Verzonden: dinsdag 22 december 2015 10:32
Aan: Kristof VAN DEN EYNDEN
CC: users@ovirt.org
Onderwerp: Re: [ovirt-users] network configuration oVirt 3.5

Hi Kristof.
By inspecting the logs (supervdsm.log) I see the following:
Adding the management network on the host started here:

MainProcess|jsonrpc.Executor/4::DEBUG::2015-12-21 
15:40:04,620::supervdsmServer::114::SuperVdsm.ServerCallback::(wrapper) call 
setupNetworks with ({u'ovirtmgmt': {u'nic': u'enp3s0', u'mtu': u'1500', 
u'bootproto': u'dhcp', u'STP': u'no', u'bridged': u'true', u'defaultRoute': 
True}}, {}, {u'connectivityCheck': u'true', u'connectivityTimeout': 120}) {}
as part of the network configuration vdsm tries to call `ifup` on the bridge 
named ovirtmgmt:

ifup-waiting-on-dhcp::DEBUG::2015-12-21 
15:40:04,854::utils::669::root::(execCmd) /usr/bin/systemd-run --scope 
--unit=8bcdacee-4849-453d-a68f-2251e168d466 --slice=vdsm-dhclient 
/usr/sbin/ifup ovirtmgmt (cwd None)
This fails after ~1 minute:

ifup-waiting-on-dhcp::DEBUG::2015-12-21 
15:41:08,184::utils::687::root::(execCmd) FAILED: <err> = 'Running as unit 
8bcdacee-4849-453d-a68f-2251e168d466.scope.\n'; <rc> = 1
and then the vdsm gives up after 2 minuets (see the parameter: 
u'connectivityTimeout': 120) when it no longer hears the keepalive ping from 
the engine.
I guess that somehow the DHCP process on your network is not operating properly.
To work around this (until you sort out the DHCP issues)- configure ovirtmgmt 
management to have a static IP.
Ido


On Mon, Dec 21, 2015 at 4:04 PM, Kristof VAN DEN EYNDEN 
<kristof.vandeneyn...@politiewestkust.be<mailto:kristof.vandeneyn...@politiewestkust.be>>
 wrote:
Hey Dan,

I reïnstalled the 3.6 on CentOS 7 (this was the issue as vdsm is no longre 
build for 6.7).
It's a fresh install of CentOs, only configured the adapter for a static IP and 
then the install of the oVirt Node.
 Installation goes well until following errors popup:


Dec 21, 2015 3:42:45 PM
Host KVM1 installation failed. Failed to configure management network on the 
host.

Dec 21, 2015 3:42:45 PM
Failed to configure management network on host KVM1 due to setup networks 
failure.

Dec 21, 2015 3:42:45 PM
VDSM KVM1 command failed: connectivity check failed

I included both vdsm.log  & supervdsm.log

---

I did a reboot, the ovirtmgmt was not linked to the adapter (enp3s0). Tried to 
link it manually which worked without hassle...

So now everything seems OK. I'll test further with the 3.6 now and hope it all 
goes like this now

-----Oorspronkelijk bericht-----
Van: users-boun...@ovirt.org<mailto:users-boun...@ovirt.org> 
[mailto:users-boun...@ovirt.org<mailto:users-boun...@ovirt.org>] Namens Kristof 
VAN DEN EYNDEN
Verzonden: maandag 21 december 2015 11:41
Aan: 'users@ovirt.org<mailto:users@ovirt.org>'
Onderwerp: Re: [ovirt-users] network configuration oVirt 3.5

Hey Dan,

Thanks for your response.

VDSM was the first problem when installing oVirt 3.6 on CentOS, it couldn't 
find the package and while browsing through the repos I couldn't find it 
either. So that was the first issue.. I tried compiling vdsm myself which 
didn't work either and I ended up using the VDSM package under the 3.5 release. 
Any idea how to tackle this?

If I have the time I'll try to reinstall 3.6 and note all the issues I find on 
the way. Can't recover those files as the server is complete messed up after my 
previous efforts

Kind regards !
Kristof




-----Oorspronkelijk bericht-----
Van: Dan Kenigsberg [mailto:dan...@redhat.com<mailto:dan...@redhat.com>]
Verzonden: maandag 21 december 2015 11:19
Aan: Kristof VAN DEN EYNDEN; edwa...@redhat.com<mailto:edwa...@redhat.com>
CC: 'users@ovirt.org<mailto:users@ovirt.org>'
Onderwerp: Re: [ovirt-users] network configuration oVirt 3.5

On Thu, Dec 17, 2015 at 03:33:28PM +0000, Kristof VAN DEN EYNDEN wrote:
> Hello everyone,
>
> After trying to install oVirt 3.6 on CentOs which was a lot of pain, I ended 
> up installing 3.5 without hassle.

Would you provide more information (logs, screenshots) about the pains of 
installing ovirt-3.6? These days, most of the development effort is focused on 
stabilizing 3.6. No further releases of ovirt-3.5.z are expected (up to 
horrible security bugs, etc), so we advise using 3.6 in new instllations.

>
> BUT Now I'm trying to configure the network for my first cluster host but I'm 
> having troubles doing so.
>
> The server has 4 network ports,
> Eth0 = Virtual management network, 172.16 range, only used for oVirt /
> KVM
> Eth1 = Local network where the Guest should be accessible range 11.x
> Eth2/3 unused..
>
> Initially, no network is assigned, but I feel eth0 should be linked to 
> ovirtmgmt I automatically using it's IP that is assigned?
>
> When I assign ovirtmgmt to eth0 and set the IP to the corresponding IP
> it already has for that host and the local network to eth1 the host
> loses connection (until it resets it's connections...)
> ->not assigning an IP is no option as I can only select static /dhcp
> ->for ovirtmgmt


ovirtmgmt should have been automatically added on top of the interface that has 
the IP used to add the host to Engine.

Could you share your engine.log and {super,}vdsm.log from that time to 
understand why did it happen?

Similarly, please share your ifcfg files prior to adding ovirtmgmt, and the 
supervdsm logs that end up with disconnection.

Regards,
Dan.
_______________________________________________
Users mailing list
Users@ovirt.org<mailto:Users@ovirt.org>
http://lists.ovirt.org/mailman/listinfo/users

_______________________________________________
Users mailing list
Users@ovirt.org<mailto:Users@ovirt.org>
http://lists.ovirt.org/mailman/listinfo/users



--
Thanks,
Ido Barkan
_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to