I've been giving this a new try. Unfortunately the setup script for hosted engine seems to be hardcoded to create a bridge on a physical network interface. I was somewhat successful by creating a dummy ovirtmgmt bridge interface and patching bridge.py to give back a static ip. Then the engine started up but failed later in the setup due to a faulty firewall rule.

I then thought that ok I'll restore the network config to the original settings, run the setup and then add the OpenVSwitch config. That failed even more miserably before I got that far..

As soon as vdsm activates it will write ifcfg files for eth0 and ovirtmgmt but with a config that doesn't work in my case as there are some additional parameters that are needed. For example it is missing the HWADDR setting in ifcfg-eth0. This is using the beta1 release of 4.0

Even if I boot rescue image and correct the network configuration it will again be overwritten by vdsm on boot.

I really need to make Ovirt understand that it must NOT change any network configuration on the host, just use what is provided to it and if there is something that it doesn't like then log the settings that should be changed.

How can I accomplish that?


On 2016-04-13 14:50, Dan Kenigsberg wrote:
On Mon, Apr 11, 2016 at 01:24:51PM +0200, Sverker Abrahamsson wrote:
My usecase is that I am setting up a lab to emulate a customers production
environment which has multiple vlans. As this is done in a hosting
environment where I don't have any control over the switches, I've created
virtual switches with OpenVSwitch which connects together a couple of
physical servers which are running virtual machines to emulate their
servers. Currently I'm running a few virtual machines created manually with
libvirt but looking for a more user friendly way of handling them.

I'm not looking at managing the network setup from Ovirt, I just want it to
use the network that is present and create VM's there.
In this case, you may want to define your ovs-based network in
libvirt (virsh net-define bla.xml) and use vdsm-hook-extnet to let ovirt
consume it.

The tweaking that I did with 3.6 was to run the hosted-engine setup but
where it failed I put the right answer in the file so that it would skip
over that part. I got that far that it attempts to start the vm but as it
doesn't give right parameters to libvirt it fails to create a port on the

I'm not having much luck with the 4.0 alpha though, this is a separate
machine that I set up for this testing but when I run hosted-engine --deploy
it just returns without any message. I did run the cleanup script found at
http://www.ovirt.org/documentation/how-to/hosted-engine/ and rebooted in
between but still no luck


Users mailing list

Reply via email to