On Wed, Aug 3, 2016 at 2:30 PM, nicola.gentile.to
<nicola.gentile...@gmail.com> wrote:
> Il 05/07/2016 10:30, Gianluca Cecchi ha scritto:
>
> Two final steps I've done that are only necessary in my environment, where
> the host itslef is providing the NFS service for storage domains:
>
> After install you have to make a dependency so that VDSM Broker starts after
> NFS Server
>
> In /usr/lib/systemd/system/ovirt-ha-broker.service
>
> Added in section  [Unit] the line:
>
> After=nfs-server.service
>
> Also, for vdsmd service, in file vdsmd.service changed from:
>
> After=multipathd.service libvirtd.service iscsid.service rpcbind.service \
>       supervdsmd.service sanlock.service vdsm-network.service
>
> to:
> After=multipathd.service libvirtd.service iscsid.service rpcbind.service \
>       supervdsmd.service sanlock.service vdsm-network.service \
>       nfs-server.service
>
> NOTE: the files will be overwritten by future updates, so you have to keep
> in mind...
>
> Hi,
>
> I try to upgrade from ovirt 3.6.7 to 4.0.1.
>
> I follow this steps:
>
> 1. Update repository for 4.0.1
>
> 2. Disable old repository 3.6.7
>
> 3. run: yum update "ovirt-engine-setup*"
>
> now an error occured:
>
> yum update "ovirt-engine-setup*"
> Plugin abilitati:fastestmirror, langpacks, versionlock
> Repository centos-ovirt36 is listed more than once in the configuration
> Repository virtio-win-stable is listed more than once in the configuration
> Loading mirror speeds from cached hostfile
>  * base: artfiles.org
>  * extras: ba.mirror.garr.it
>  * ovirt-4.0: ftp.nluug.nl
>  * ovirt-4.0-epel: epel.besthosting.ua
>  * updates: ba.mirror.garr.it
> Risoluzione dipendenze
> --> Esecuzione del controllo di transazione
> ---> Pacchetto ovirt-engine-setup.noarch 0:3.6.7.5-1.el7.centos settato per
> essere aggiornato
> ---> Pacchetto ovirt-engine-setup.noarch 0:4.0.1.1-1.el7.centos settato per
> essere un aggiornamento
> ---> Pacchetto ovirt-engine-setup-base.noarch 0:3.6.7.5-1.el7.centos settato
> per essere aggiornato
> ---> Pacchetto ovirt-engine-setup-base.noarch 0:4.0.1.1-1.el7.centos settato
> per essere un aggiornamento
> --> Elaborazione dipendenza: ovirt-engine-lib >= 4.0.1.1-1.el7.centos per il
> pacchetto: ovirt-engine-setup-base-4.0.1.1-1.el7.centos.noarch
> --> Elaborazione dipendenza: otopi >= 1.5.0 per il pacchetto:
> ovirt-engine-setup-base-4.0.1.1-1.el7.centos.noarch
> ---> Pacchetto ovirt-engine-setup-plugin-ovirt-engine.noarch
> 0:3.6.7.5-1.el7.centos settato per essere aggiornato
> ---> Pacchetto ovirt-engine-setup-plugin-ovirt-engine.noarch
> 0:4.0.1.1-1.el7.centos settato per essere un aggiornamento
> --> Elaborazione dipendenza: ovirt-engine-dwh-setup >= 4.0 per il pacchetto:
> ovirt-engine-setup-plugin-ovirt-engine-4.0.1.1-1.el7.centos.noarch
> ---> Pacchetto ovirt-engine-setup-plugin-ovirt-engine-common.noarch
> 0:3.6.7.5-1.el7.centos settato per essere aggiornato
> ---> Pacchetto ovirt-engine-setup-plugin-ovirt-engine-common.noarch
> 0:4.0.1.1-1.el7.centos settato per essere un aggiornamento
> ---> Pacchetto ovirt-engine-setup-plugin-vmconsole-proxy-helper.noarch
> 0:3.6.7.5-1.el7.centos settato per essere aggiornato
> ---> Pacchetto ovirt-engine-setup-plugin-vmconsole-proxy-helper.noarch
> 0:4.0.1.1-1.el7.centos settato per essere un aggiornamento
> ---> Pacchetto ovirt-engine-setup-plugin-websocket-proxy.noarch
> 0:3.6.7.5-1.el7.centos settato per essere aggiornato
> ---> Pacchetto ovirt-engine-setup-plugin-websocket-proxy.noarch
> 0:4.0.1.1-1.el7.centos settato per essere un aggiornamento
> --> Esecuzione del controllo di transazione
> ---> Pacchetto otopi.noarch 0:1.4.2-1.el7.centos settato per essere
> aggiornato
> --> Elaborazione dipendenza: otopi = 1.4.2-1.el7.centos per il pacchetto:
> otopi-java-1.4.2-1.el7.centos.noarch
> ---> Pacchetto otopi.noarch 0:1.5.1-1.el7.centos settato per essere un
> aggiornamento
> ---> Pacchetto ovirt-engine-dwh-setup.noarch 0:3.6.6-1.el7.centos settato
> per essere aggiornato
> ---> Pacchetto ovirt-engine-dwh-setup.noarch 0:4.0.1-1.el7.centos settato
> per essere un aggiornamento
> ---> Pacchetto ovirt-engine-lib.noarch 0:3.6.7.5-1.el7.centos settato per
> essere aggiornato
> ---> Pacchetto ovirt-engine-lib.noarch 0:4.0.1.1-1.el7.centos settato per
> essere un aggiornamento
> --> Esecuzione del controllo di transazione
> ---> Pacchetto otopi-java.noarch 0:1.4.2-1.el7.centos settato per essere
> aggiornato
> ---> Pacchetto otopi-java.noarch 0:1.5.1-1.el7.centos settato per essere un
> aggiornamento
> --> Analisi conflitto: ovirt-engine-setup-base-4.0.1.1-1.el7.centos.noarch
> va in conflitto con ovirt-engine-reports-setup < 4.0.0
> --> Risoluzione delle dipendenze completata
> Errore: ovirt-engine-setup-base conflicts with
> ovirt-engine-reports-setup-3.6.5.1-1.el7.centos.noarch
>  Si può provare ad usare --skip-broken per aggirare il problema
> ** Trovati 19 problemi pre-esistenti nel rpmdb, l'output di 'yum check' è:
> bash-4.2.46-20.el7_2.x86_64 è un duplicato di bash-4.2.46-19.el7.x86_64
> 1:dbus-1.6.12-14.el7_2.x86_64 è un duplicato di 1:dbus-1.6.12-13.el7.x86_64
> 1:dbus-libs-1.6.12-14.el7_2.x86_64 è un duplicato di
> 1:dbus-libs-1.6.12-13.el7.x86_64
> glibc-2.17-106.el7_2.8.x86_64 è un duplicato di
> glibc-2.17-106.el7_2.6.x86_64
> glibc-common-2.17-106.el7_2.8.x86_64 è un duplicato di
> glibc-common-2.17-106.el7_2.6.x86_64
> glibc-headers-2.17-106.el7_2.8.x86_64 è un duplicato di
> glibc-headers-2.17-106.el7_2.6.x86_64
> gssproxy-0.4.1-8.el7_2.x86_64 è un duplicato di gssproxy-0.4.1-7.el7.x86_64
> 1:java-1.7.0-openjdk-1.7.0.111-2.6.7.2.el7_2.x86_64 è un duplicato di
> 1:java-1.7.0-openjdk-1.7.0.101-2.6.6.1.el7_2.x86_64
> 1:java-1.7.0-openjdk-headless-1.7.0.111-2.6.7.2.el7_2.x86_64 è un duplicato
> di 1:java-1.7.0-openjdk-headless-1.7.0.101-2.6.6.1.el7_2.x86_64
> libblkid-2.23.2-26.el7_2.3.x86_64 è un duplicato di
> libblkid-2.23.2-26.el7_2.2.x86_64
> libmount-2.23.2-26.el7_2.3.x86_64 è un duplicato di
> libmount-2.23.2-26.el7_2.2.x86_64
> libsss_idmap-1.13.0-40.el7_2.12.x86_64 è un duplicato di
> libsss_idmap-1.13.0-40.el7_2.9.x86_64
> libsss_nss_idmap-1.13.0-40.el7_2.12.x86_64 è un duplicato di
> libsss_nss_idmap-1.13.0-40.el7_2.9.x86_64
> libuuid-2.23.2-26.el7_2.3.x86_64 è un duplicato di
> libuuid-2.23.2-26.el7_2.2.x86_64
> 2:microcode_ctl-2.1-12.el7_2.1.x86_64 è un duplicato di
> 2:microcode_ctl-2.1-12.el7.x86_64
> systemd-219-19.el7_2.12.x86_64 è un duplicato di
> systemd-219-19.el7_2.11.x86_64
> systemd-libs-219-19.el7_2.12.x86_64 è un duplicato di
> systemd-libs-219-19.el7_2.11.x86_64
> systemd-sysv-219-19.el7_2.12.x86_64 è un duplicato di
> systemd-sysv-219-19.el7_2.11.x86_64
> util-linux-2.23.2-26.el7_2.3.x86_64 è un duplicato di
> util-linux-2.23.2-26.el7_2.2.x86_64
>
> What can I do to solve the problem?

Reports is not packaged nor supported in 4.0.

If you don't need it, you can try:

yum remove ovirt-engine-reports\*

If you do, you might be able to set up Reports 3.6 to
work with your 4.0 engine/dwh.

On a side note, it's recommended to remove your 3.6 repos
only after you finished upgrading to 4.0 - if you remove them
before, engine-setup will not be able to rollback in case of
a problem.

Best,
-- 
Didi
_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to