Hi all,

I just recently started testing out oVirt in our lab.  I’m using CentOS 7 on my 
hosts and using the hosted-engine model, and the oVirt 3.6 repository.  I have 
NFS storage.  I ran across what I think is a bug of some sort, and I’m curious 
if anyone else has tried this or know what’s going on.

I wanted to be able to expose the NFS server (not necessarily the share used 
for oVirt storage domains, but other shares on the NFS server) to VMs running 
on my host (currently my setup only involves a single host). I have two 
10GbaseT interfaced bonded together on the hose with two VLAN networks on it 
currently, one for the management network, one for storage.  When the 
hosted-engine deployment was set up, I ended up with an ovirtmgmt interface 
that was bridged to my infrastructure vlan interface (vlan 1080).  So, I added 
another network in my oVirt cluster named VM-Storage with vlan 1092 (my storage 
network).  Here is approximately how I expected this to end up:

bond0 - (bonded interface)
  - bond0.1092 (STORAGE - vlan interface)
     - VM-storage (bridged interface)
  - bond0.1080 (INFR - van interface)
    - ovirtmgmt (bridged interface)

However, when I did network setup on the host, and dragged the VM-Storage 
network over to the network interface and hit OK, the UI just froze, and for a 
few seconds I checked on the host via ssh session and the VM-storage bridge was 
setup, then the server just rebooted.  After it rebooted, my vlan interface was 
no longer there and it seems like both the hosted engine VM and the host ended 
up being rebooted.  In thinking about it, I may have caused at least a 
temporary outage with my NFS storage when the new bridged interface was set up 
which caused (maybe) the HA agent to think the hosted engine vm went away or 
something, and that cause the reboots.  Not entirely sure, but this was 
certainly unexpected.  I have tried several times and the same result each time.

I did check that any other VM network with a different VLAN ID provisions just 
fine on the host, so I assume there’s something that happens when this storage 
network is provisioned that is catching oVirt off-guard somehow.

Anyone else have this issue before?  Can I solve this by adding another host, 
then moving the hosted-engine to a different host while I add the storage 
network to each host?


Kendal Montgomery
Lab Manager
O: 614.407.5584 | M: 614.571.0172

Users mailing list

Reply via email to