Hello. I got the error mentioned in the subject when when trying to
build ovirt-host-deploy. Full output here:
https://paste.fedoraproject.org/paste/Dh7FF1XjhDa2TGNSBs~o815M1UNdIGYhyRLivL9gydE=

The troubleshooting I've done so far is as follows:
1. Rebuilt otopi, running the commands `autoreconf -ivf` and then
`./configure --enable-java-sdk --with-maven`. This made `make`
download a host of stuff for otopi project from
https://repo.maven.apache.org
It did this again when I ran `make install`. When I went back to the
ovirt-host-deploy directory, I ran `./configure`, both with the
--enable-java-sdk and --with-maven options. Got the same error again.

2. I tried running entering the directory src/java and running `mvn
install`. I received a build success message and then proceeded to run

./configure --build=x86_64-linux-gnu --host=x86_64-linux-gnu
--program-prefix= --prefix=/usr --exec-prefix=/usr --bindir=/usr/bin
--sbindir=/usr/sbin --sysconfdir=/etc --datadir=/usr/share
--includedir=/usr/include --libdir=/usr/lib64
--libexecdir=/usr/libexec --localstatedir=/var
--sharedstatedir=/var/lib --mandir=/usr/share/man
--disable-python-syntax-check --enable-java-sdk
--with-local-version=otopi-1.7.0.master
COMMONS_LOGGING_JAR=/usr/share/java/commons-logging.jar
JUNIT_JAR=/usr/share/java/junit.jar

I omitted the --disable-dependency-tracking and
--docdir=/usr/share/doc/otopi-1.7.0 options because of the following
error: configure: WARNING: unrecognized options:
--disable-dependency-tracking and the fact that I didn't have the
directory /usr/share/doc/otopi-1.7.0 respectively. I got the following
output: 
https://paste.fedoraproject.org/paste/90D0k1AyVPGDbNhk1WxlBl5M1UNdIGYhyRLivL9gydE=

Running `sudo make install` gives me the same errors. It seems otopi
is failing to compile properly and as a result, running ./configure
within the ovirt-host-deploy directory ends with an error saying
otopi-devtools are missing. Documentation of my environment as it
stands is here:
https://github.com/leni1/oVirt-docs-Debian/blob/master/oVirt-Development-Environment.md

Any ideas on what I should try next are welcome.

-- 
- Warm regards
Leni Kadali Mutungi
_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to