On Fri, Mar 23, 2018 at 3:20 PM, <nico...@devels.es> wrote:

> El 2018-03-23 12:16, Sandro Bonazzola escribió:
>
>> 2018-03-21 13:37 GMT+01:00 <nico...@devels.es>:
>>
>> Hi,
>>>
>>> We're running oVirt 4.1.9, today I put a host on maintenance, I saw
>>> one of the VMs was taking too long to migrate so I shut it down. It
>>> seems that just in that moment the machine ended migrating, but the
>>> shutdown did happen as well.
>>>
>>
>> I would suggest to update to 4.2 as soon as possible since 4.1 is not
>> supported anymore now that 4.2 is available
>>
>>
> We have 2 oVirt infrastructures. One is migrated to 4.2, we can't migrate
> the other one since most of the user portal features in 4.1 are not present
> in 4.2 and our users do a massive usage of this portal to create/tune VMs.
> I know several issues were created on Github to implement missing features,
> but we cannot upgrade until they are implemented.
>

Have you checked the latest oVirt 4.2.2 RC? We have brought back several
features to the user portal.
Y.


>
> Thanks.
>
>
>>
>> Now, when I try to start the VM I'm getting the following error:
>>>
>>> 2018-03-21 12:31:02,309Z ERROR
>>>
>>> [org.ovirt.engine.core.dal.dbbroker.auditloghandling.AuditLogDirector]
>>
>>> (DefaultQuartzScheduler3) [7985a4e2] EVENT_ID: VM_DOWN_ERROR(119),
>>> Correlation ID: null, Call Stack: null, Custom ID: null, Custom
>>> Event ID: -1, Message: VM openmaint.iaas.domain.com [1] is down with
>>> error. Exit message: Bad volume specification {'index': '0',
>>> u'domainID': u'04cb5bd0-d94e-4d14-a71a-e63a669e11b9', 'reqsize':
>>> '0', u'format': u'cow', u'optional': u'false', u'address':
>>> {u'function': u'0x0', u'bus': u'0x00', u'domain': u'0x0000',
>>> u'type': u'pci', u'slot': u'0x06'}, u'volumeID':
>>> u'68ee7a04-ceff-49f0-bf91-256870543921', 'apparentsize':
>>> '3221225472', u'imageID': u'9d087e6b-0832-46db-acb0-16d5131afa0c',
>>> u'discard': False, u'specParams': {}, u'readonly': u'false',
>>> u'iface': u'virtio', u'deviceId':
>>> u'9d087e6b-0832-46db-acb0-16d5131afa0c', 'truesize': '3221225472',
>>> u'poolID': u'75bf8f48-970f-42bc-8596-f8ab6efb2b63', u'device':
>>> u'disk', u'shared': u'false', u'propagateErrors': u'off', u'type':
>>> u'disk'}.
>>>
>>> It looks quite bad... I'm attaching the engine.log since the moment
>>> I start the VM.
>>>
>>> Is there anything I can do to recover the VM? oVirt says the disk
>>> is OK in the 'Disks' tab.
>>>
>>
>> Adding some people who may be able to help. Once solved, please
>> consider upgrade.
>>
>>
>>
>> Thanks.
>>> _______________________________________________
>>> Users mailing list
>>> Users@ovirt.org
>>> http://lists.ovirt.org/mailman/listinfo/users [2]
>>>
>>
>> --
>>
>> SANDRO BONAZZOLA
>>
>> ASSOCIATE MANAGER, SOFTWARE ENGINEERING, EMEA ENG VIRTUALIZATION R&D
>>
>> Red Hat EMEA [3]
>>
>> sbona...@redhat.com
>>
>>                  [4]
>>
>>  [5]
>>
>>
>>
>> Links:
>> ------
>> [1] http://openmaint.iaas.domain.com
>> [2] http://lists.ovirt.org/mailman/listinfo/users
>> [3] https://www.redhat.com/
>> [4] https://red.ht/sig
>> [5] https://redhat.com/summit
>>
> _______________________________________________
> Users mailing list
> Users@ovirt.org
> http://lists.ovirt.org/mailman/listinfo/users
>
_______________________________________________
Users mailing list
Users@ovirt.org
http://lists.ovirt.org/mailman/listinfo/users

Reply via email to