On 03.08.2018 15:52, Gianluca Cecchi wrote:
On Fri, Aug 3, 2018 at 2:14 PM, Jan Siml <js...@plusline.net <mailto:js...@plusline.net>> wrote:


        There are probably some more stale image transfers records,
        can you please check whether 'image_transfers' table is empty?
        If not, you can try removing them by executing:
        "DELETE FROM image_transfers WHERE command_id NOT IN (SELECT
        command_entities.command_id FROM command_entities);"
        (you can simply prepend it to

    that's how it worked and the update was successful. Thanks!

are you saying that after your second update failure that failed also the the restore of the databases, you added the delete statement into the 04_02_1210_add_foreign_key_to_image_transfers.sql script? How? because the yum rollback phase completed in my case so under /usr/share/ovirt-engine/dbscripts/upgrade/ I currently don't have it...
And the first update error leaves the engine down....

I checked the table in psql and found only one row. Then I used the above statement to delete the orphaned row and retried the update. Worked.


Users mailing list -- users@ovirt.org
To unsubscribe send an email to users-le...@ovirt.org
Privacy Statement: https://www.ovirt.org/site/privacy-policy/
oVirt Code of Conduct: 
List Archives: 

Reply via email to